Initial import. Haskell library. An efficient implementation of Int-indexed arrays...
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 12 Jan 2012 16:55:23 +0000 (16:55 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 12 Jan 2012 16:55:23 +0000 (16:55 +0000)
Package-Manager: portage-2.2.0_alpha84_p18/cvs/Linux x86_64

dev-haskell/vector/ChangeLog [new file with mode: 0644]
dev-haskell/vector/metadata.xml [new file with mode: 0644]
dev-haskell/vector/vector-0.9.1.ebuild [new file with mode: 0644]

diff --git a/dev-haskell/vector/ChangeLog b/dev-haskell/vector/ChangeLog
new file mode 100644 (file)
index 0000000..7ad781a
--- /dev/null
@@ -0,0 +1,12 @@
+# ChangeLog for dev-haskell/vector
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector/ChangeLog,v 1.1 2012/01/12 16:55:23 slyfox Exp $
+
+*vector-0.9.1 (12 Jan 2012)
+
+  12 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+  +vector-0.9.1.ebuild:
+  Initial import. Haskell library. An efficient implementation of Int-indexed
+  arrays (both mutable and immutable) with powerful loop optimization framework.
+  Depend for dev-util/bustle-0.3.1.
+
diff --git a/dev-haskell/vector/metadata.xml b/dev-haskell/vector/metadata.xml
new file mode 100644 (file)
index 0000000..3c930fc
--- /dev/null
@@ -0,0 +1,69 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>haskell</herd>
+       <maintainer>
+               <email>haskell@gentoo.org</email>
+       </maintainer>
+       <longdescription>
+               
+               An efficient implementation of Int-indexed arrays (both mutable
+               and immutable), with a powerful loop optimisation framework .
+               
+               It is structured as follows:
+               
+               [&quot;Data.Vector&quot;] Boxed vectors of arbitrary types.
+               
+               [&quot;Data.Vector.Unboxed&quot;] Unboxed vectors with an adaptive
+               representation based on data type families.
+               
+               [&quot;Data.Vector.Storable&quot;] Unboxed vectors of &#39;Storable&#39; types.
+               
+               [&quot;Data.Vector.Primitive&quot;] Unboxed vectors of primitive types as
+               defined by the @primitive@ package. &quot;Data.Vector.Unboxed&quot; is more
+               flexible at no performance cost.
+               
+               [&quot;Data.Vector.Generic&quot;] Generic interface to the vector types.
+               
+               Each module has a @Safe@ version with is marked as @Trustworthy@
+               (see &lt;http://hackage.haskell.org/trac/ghc/wiki/SafeHaskell&gt;).
+               
+               There is also a (draft) tutorial on common uses of vector.
+               
+               * &lt;http://haskell.org/haskellwiki/Numeric_Haskell:_A_Vector_Tutorial&gt;
+               
+               Please use the project trac to submit bug reports and feature
+               requests.
+               
+               * &lt;http://trac.haskell.org/vector&gt;
+               
+               Changes in version 0.9
+               
+               * &#39;MonadPlus&#39; instance for boxed vectors
+               
+               * Export more @construct@ and @constructN@ from @Safe@ modules
+               
+               * Require @primitive-0.4.0.1@
+               
+               Changes in version 0.8
+               
+               * New functions: @constructN@, @constructrN@
+               
+               * Support for GHC 7.2 array copying primitives
+               
+               * New fixity for @(!)@
+               
+               * Safe Haskell support (contributed by David Terei)
+               
+               * &#39;Functor&#39;, &#39;Monad&#39;, &#39;Applicative&#39;, &#39;Alternative&#39;, &#39;Foldable&#39; and
+               &#39;Traversable&#39; instances for boxed vectors
+               (/WARNING: they tend to be slow and are only provided for completeness/)
+               
+               * &#39;Show&#39; instances for immutable vectors follow containers conventions
+               
+               * &#39;Read&#39; instances for all immutable vector types
+               
+               * Performance improvements
+               
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/vector/vector-0.9.1.ebuild b/dev-haskell/vector/vector-0.9.1.ebuild
new file mode 100644 (file)
index 0000000..7a0f111
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector/vector-0.9.1.ebuild,v 1.1 2012/01/12 16:55:23 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient Arrays"
+HOMEPAGE="http://code.haskell.org/vector"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/primitive-0.4*
+               >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+               >=dev-haskell/cabal-1.2.3"