www-client/firefox-bin: don't install -x11 shortcut/.desktop file when not needed
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 15:42:31 +0000 (17:42 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 15:43:01 +0000 (17:43 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild
www-client/firefox-bin/firefox-bin-74.0-r1.ebuild

index eb30ac30836f9033d1eb187f47a2680c2c5eb253..77ed113988e864c9452ca85f784b48d03223b763 100644 (file)
@@ -161,11 +161,14 @@ src_install() {
                                newbin "${FILESDIR}"/firefox-bin-wayland.sh ${PN}-wayland
                                ;;
                        X11)
-                               exec_command="${PN}-x11 --name ${PN}-x11"
-                               if use wayland ; then
-                                       # Only needed when there's actually a choice
-                                       newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
+                               if ! use wayland ; then
+                                       # Exit loop here because there's no choice so
+                                       # we don't need wrapper/.desktop file for X11.
+                                       continue
                                fi
+
+                               exec_command="${PN}-x11 --name ${PN}-x11"
+                               newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
                                ;;
                        *)
                                app_name="${name}"
index f8f296dafd156e934253017f580bbfdff4ecb91c..85a96b9928c81af47f9faa836e0996ae04045abe 100644 (file)
@@ -161,11 +161,14 @@ src_install() {
                                newbin "${FILESDIR}"/firefox-bin-wayland.sh ${PN}-wayland
                                ;;
                        X11)
-                               exec_command="${PN}-x11 --name ${PN}-x11"
-                               if use wayland ; then
-                                       # Only needed when there's actually a choice
-                                       newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
+                               if ! use wayland ; then
+                                       # Exit loop here because there's no choice so
+                                       # we don't need wrapper/.desktop file for X11.
+                                       continue
                                fi
+
+                               exec_command="${PN}-x11 --name ${PN}-x11"
+                               newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
                                ;;
                        *)
                                app_name="${name}"