net-misc/ntp: fix building against GCC 10
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 2 May 2020 18:59:34 +0000 (20:59 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 2 May 2020 18:59:50 +0000 (20:59 +0200)
Closes: https://bugs.gentoo.org/707688
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-misc/ntp/files/ntp-4.2.8-gcc10-fno-common.patch [new file with mode: 0644]
net-misc/ntp/ntp-4.2.8_p14-r2.ebuild

diff --git a/net-misc/ntp/files/ntp-4.2.8-gcc10-fno-common.patch b/net-misc/ntp/files/ntp-4.2.8-gcc10-fno-common.patch
new file mode 100644 (file)
index 0000000..d2ed719
--- /dev/null
@@ -0,0 +1,22 @@
+--- ntp-4.2.8p14/include/ntp_config.h.psl
++++ ntp-4.2.8p14/include/ntp_config.h
+@@ -280,7 +280,7 @@ typedef struct settrap_parms_tag {
+  * Poll Skew List
+  */
+-psl_item psl[17-3+1];         /* values for polls 3-17 */
++extern psl_item psl[17-3+1];  /* values for polls 3-17 */
+                               /* To simplify the runtime code we */
+                               /* don't want to have to special-case */
+                               /* dealing with a default */
+--- ntp-4.2.8p14/ntpd/ntp_config.c.psl
++++ ntp-4.2.8p14/ntpd/ntp_config.c
+@@ -202,6 +202,8 @@ int        cryptosw;               /* crypto command called
+ extern char *stats_drift_file;        /* name of the driftfile */
++psl_item psl[17-3+1];        /* values for polls 3-17 */
++
+ #ifdef BC_LIST_FRAMEWORK_NOT_YET_USED
+ /*
+  * backwards compatibility flags
index b2cbb8b926a93f12af6987acb1994d80417a6cd3..79a6d513fa4eea999c6d1c2630e8b88135107a7d 100644 (file)
@@ -48,6 +48,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-4.2.8_p10-fix-build-wo-ssl-or-libressl.patch
        "${FILESDIR}"/${PN}-4.2.8_p12-libressl-2.8.patch
        "${FILESDIR}"/${PN}-4.2.8_p14-add_cap_ipc_lock.patch #711530
+       "${FILESDIR}"/${PN}-4.2.8-gcc10-fno-common.patch
 )
 
 src_prepare() {