sys-devel/llvm-common: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:45 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:49 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild

index 11a022242bd0aed7acc8bdf37e08beeeaee378d1..7edf27153de4417796328fd4a420bdec1f32bd4f 100644 (file)
@@ -8,8 +8,8 @@ inherit git-r3
 DESCRIPTION="Common files shared between multiple slots of LLVM"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -20,7 +20,7 @@ RDEPEND="!sys-devel/llvm:0"
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' utils/vim
+       git-r3_checkout '' '' '' llvm/utils/vim
 }
 
 src_configure() { :; }
index ae78e1164ce5f8556354a154ca3528e5dfe641ff..b3b79ac4e6c670c04690a15cbc483fdac0a14d5d 100644 (file)
@@ -8,9 +8,9 @@ inherit git-r3
 DESCRIPTION="Common files shared between multiple slots of LLVM"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -21,7 +21,7 @@ RDEPEND="!sys-devel/llvm:0"
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' utils/vim
+       git-r3_checkout '' '' '' llvm/utils/vim
 }
 
 src_configure() { :; }