dev-python/qscintilla-python: fix out-of-source builds
authorDavide Pesavento <pesa@gentoo.org>
Sun, 26 Aug 2018 17:56:31 +0000 (19:56 +0200)
committerDavide Pesavento <pesa@gentoo.org>
Sun, 26 Aug 2018 17:57:47 +0000 (19:57 +0200)
Closes: https://bugs.gentoo.org/664612
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-python/qscintilla-python/qscintilla-python-2.10.7.ebuild

index 1d3059473f9a44cd6f6aeb8724ff7430e29c1415..d9ffd92fb6cfeb2f8bdb9b5a4b40d1aaa401843c 100644 (file)
@@ -33,14 +33,16 @@ RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_P}/Python
 
+src_prepare() {
+       default
+       python_copy_sources
+}
+
 src_configure() {
        configuration() {
-               # Fix out-of-source build and installation of .sip files
-               ln -s "${S}"/sip || die
-
                local myconf=(
                        "${PYTHON}"
-                       "${S}"/configure.py
+                       configure.py
                        --pyqt=PyQt5
                        --qmake="$(qt5_get_bindir)"/qmake
                        --sip-incdir="$(python_get_includedir)"