net-misc/gsutil: version bump to 4.14
authorMike Frysinger <vapier@gentoo.org>
Sun, 30 Aug 2015 06:18:15 +0000 (02:18 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sun, 30 Aug 2015 06:18:15 +0000 (02:18 -0400)
net-misc/gsutil/Manifest
net-misc/gsutil/files/gsutil-4.14-use-friendy-version-checks.patch [new file with mode: 0644]
net-misc/gsutil/gsutil-4.14.ebuild [new file with mode: 0644]

index a0f84c85de8a0046460b855398925d444b4f7bb0..ff1cac9fa90bb7c6fff1edac86c2618e72c0aa27 100644 (file)
@@ -1,2 +1,3 @@
 DIST gsutil_3.42.tar.gz 1878904 SHA256 50fc7acb7d1db8752f3eee106a3d8d65188107943e7cb30cfd3f94a9cfcdcf37 SHA512 084aaf43a44528af0cdfd9bd22beeb5d6abff240c09843cf35016d685d51b854ed5b2837eaa50c97bb44d5e1a3cdccbae6688ef27aa13f2a5db6040bf501b381 WHIRLPOOL 5b0d0fb1d2446a7b8777f368f073fdb4f7ad2d6407735976c178a2727a2548bf28522e06469dd0b7df1578d5586bc152fba3520b66f88d706417947aa3aa5578
 DIST gsutil_4.13.tar.gz 2790817 SHA256 f6fa8a77ff0475ba4898b2a4453ed3ead551499485000420f12bc4f7cfbcc09e SHA512 b146c8ce6fba09b07a752842d1ca3f83c74250553a4dae50ce32bf8ece2ded366e1b60d5c0af3727e2f5ed8d0766c9345bbf1056c3af571a26d2ed76187b57c9 WHIRLPOOL 5a989c51a9e550523713dc658255036a044f0e88dfd3869ca362d573bae6ff83004bb3249674b15fe6082b666d3c598a6f133c9b2e3c7e373a20f5db54b6d361
+DIST gsutil_4.14.tar.gz 2824826 SHA256 225d0a58c0a5ee98830efc7d5524ec4d4779304c08c80ecb608d83d9b209b4cb SHA512 a74993406786fe33b17539f62e0384084b692793746bb78b17fbca8b6a3ff840ab6d500cd4b0911f1cf176b3629ffc7f879dd056d0324e601c3a4dc499a9dedd WHIRLPOOL bd7e85887f343b96535cc4f33ddf26b847bc4275de25644582123c444fb6748cf78b67c614eec94faf38c3aa474a3ba362579e6190566bfd7b63919191658d46
diff --git a/net-misc/gsutil/files/gsutil-4.14-use-friendy-version-checks.patch b/net-misc/gsutil/files/gsutil-4.14-use-friendy-version-checks.patch
new file mode 100644 (file)
index 0000000..2ca1c81
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/setup.py
++++ b/setup.py
+@@ -35,10 +35,10 @@
+ """
+ requires = [
+-    'boto==2.38.0',
++    'boto>=2.38.0',
+     'crcmod>=1.7',
+     'gcs-oauth2-boto-plugin>=1.9',
+-    'google-apitools==0.4.9',
++    'google-apitools>=0.4.9',
+     'httplib2>=0.8',
+     'oauth2client>=1.4.11',
+     'protorpc>=0.10.0',
+@@ -48,7 +48,7 @@
+     'six>=1.8.0',
+     # Not using 1.02 because of:
+     #   https://code.google.com/p/socksipy-branch/issues/detail?id=3
+-    'SocksiPy-branch==1.01',
++    'SocksiPy-branch>=1.01',
+ ]
+ dependency_links = [
diff --git a/net-misc/gsutil/gsutil-4.14.ebuild b/net-misc/gsutil/gsutil-4.14.ebuild
new file mode 100644 (file)
index 0000000..e47100c
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="command line tool for interacting with cloud storage services"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/gsutil"
+SRC_URI="http://commondatastorage.googleapis.com/pub/${PN}_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+       >=dev-python/boto-2.38.0[${PYTHON_USEDEP}]
+       >=dev-python/crcmod-1.7[${PYTHON_USEDEP}]
+       >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+       >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+       >=dev-python/gcs-oauth2-boto-plugin-1.9[${PYTHON_USEDEP}]
+       >=dev-python/google-apitools-0.4.9[${PYTHON_USEDEP}]
+       >=dev-python/oauth2client-1.4.11[${PYTHON_USEDEP}]
+       >=dev-python/protorpc-0.10.0[${PYTHON_USEDEP}]
+       >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
+       >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/socksipy-1.01[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( README.md CHANGES.md )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.14-use-friendy-version-checks.patch
+)
+
+python_test() {
+       export BOTO_CONFIG=${FILESDIR}/dummy.boto
+       ${PYTHON} gslib/__main__.py test -u || die "tests failed"
+}