dev-python/setuptools_scm: Bump to 3.5.0
authorMichał Górny <mgorny@gentoo.org>
Fri, 14 Feb 2020 05:41:46 +0000 (06:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 14 Feb 2020 07:50:56 +0000 (08:50 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools_scm/Manifest
dev-python/setuptools_scm/setuptools_scm-3.5.0.ebuild [new file with mode: 0644]

index 3110da3cb7d7c2f1724501babc89e08cadf29573..0a7151f2357c8c65769f5771469e6272ab47be2f 100644 (file)
@@ -4,3 +4,4 @@ DIST setuptools_scm-3.2.0.tar.gz 39646 BLAKE2B 922e2e09a9826e8573900e8d279daf937
 DIST setuptools_scm-3.3.1.tar.gz 40183 BLAKE2B 417cb000c3edba7da8e92b8fb5b1d906d2ef0170eecc4c0b9d2ea490ef6bad4cbf5ca172bee0fc536c83605d361604c728bf4097f520ef8e62ee2d4f004e3db1 SHA512 cd8f3d1e97743097791001197c18a2c8336b9e499a543ec5d1ab6e9b613ef1417b59e34c329507a73c2626506ee892ccaee74dddc5c0950ff71c0bdfba954dc3
 DIST setuptools_scm-3.4.2.tar.gz 45512 BLAKE2B 4c44b85f36c4b3c5279e17e95fa54916e09a6fe7db359bc366d803796ed975c7cf8d643c5a648f25d822bd6a461c83fc08e987f2a240b15df53f27ac18558031 SHA512 bdfe0e1d3952be9f55b9d7a00a8623f58fc3fb81d78baafd80cf0bec43dd89cc6df6de547012d3b4bfcdfc709895b6cc7534adb631990470a015eb1199a99bbf
 DIST setuptools_scm-3.4.3.tar.gz 45549 BLAKE2B 89d6438d8edc5efe2a2c435a85f0bf513fbd1af7fee6630ff8b2e542733d8af8f080ac746c949ee45cf97a46077150cdd842ea5252159aedb183f7f562922bb1 SHA512 455344ac7dda5c0ac79bdb26bef020cafc116fe59b979601351c78d26806e6e610774979f74762c113926e8b022e7b58513f25010ef7b92e5104fc1b2d552d4e
+DIST setuptools_scm-3.5.0.tar.gz 46272 BLAKE2B 132711c8312dfbe48f9e2d3d7fcd0a86b057bbcf9a5f6b2e61afe018e116a4df96c3bf5cddf067bc92b96915f70182013749ce65b8fa5feb92ccef903859ee3f SHA512 f7e2cdae7a8a3d5ef3d12effcda5ce7f362c426e11aecaef69ef604bede9abbab2aa1eee6f5310cdd72a9bf11a927dbd1f42671e28bd467ad7b15f2dba5b81d9
diff --git a/dev-python/setuptools_scm/setuptools_scm-3.5.0.ebuild b/dev-python/setuptools_scm/setuptools_scm-3.5.0.ebuild
new file mode 100644 (file)
index 0000000..6832733
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.org/project/setuptools_scm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/toml[${PYTHON_USEDEP}]
+               dev-vcs/git
+               dev-vcs/mercurial )"
+
+python_prepare_all() {
+       # network access
+       sed -i -e 's:test_pip_download:_&:' testing/test_regressions.py || die
+       # all fetch specific setuptools versions
+       rm testing/test_setuptools_support.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       distutils_install_for_testing
+       pytest -v -v -x || die "Tests fail with ${EPYTHON}"
+}