app-misc/g810-led: Bump to 0.3.4
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sun, 26 May 2019 11:52:16 +0000 (13:52 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Jun 2019 10:12:01 +0000 (12:12 +0200)
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-misc/g810-led/Manifest
app-misc/g810-led/g810-led-0.3.4.ebuild [new file with mode: 0644]

index e822820b6ca14f3fe45c5d3c12c2a1d549021a61..b6cbbbdfd36d52e810d6bf6c61249b576513bf69 100644 (file)
@@ -1 +1,2 @@
 DIST g810-led-0.3.1.tar.gz 34069 BLAKE2B ebc83e1f0908e521573f6ea812c1893e8314548dbe30cad4a8f2af171eaf7f73ba905f6e01eafe9bca6c1bf006d626086091c871c6382dcd9a58caa76173ca59 SHA512 62bf73a897f8c1c967ce64f6e352d55b08af764b2aac8ce722906cdc67db28676bc5665d1ba307f0c43360e57d53e75fa39aea29ca7aa6da2e125782ae38446c
+DIST g810-led-0.3.4.tar.gz 34549 BLAKE2B 7816fc7d9892f0e7bde5369612c1b251b2b64846b68ddc795b4ca777b6369ef3e8a0a70b797883edb5d220af6a4905e55ceb24c53dbba307cf8589fe7c2cf232 SHA512 3ec460f6994adcf58c2fa024433544c83bac789981f31605ba4e4eeec255864e00fe2bcd485c1867fce9d2df9ab7313f88cbd7bcc1bab8d805dc560955386b59
diff --git a/app-misc/g810-led/g810-led-0.3.4.ebuild b/app-misc/g810-led/g810-led-0.3.4.ebuild
new file mode 100644 (file)
index 0000000..2e51fcb
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd udev eutils
+
+DESCRIPTION="Led controller for Logitech G- Keyboards"
+HOMEPAGE="https://github.com/MatMoul/g810-led"
+SRC_URI="https://github.com/MatMoul/g810-led/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+hidapi"
+
+RDEPEND="
+       hidapi? ( dev-libs/hidapi:= )
+       !hidapi? ( virtual/libusb:= )
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=("README.md" "sample_profiles" "sample_effects")
+
+src_compile() {
+       emake LIB="$(usex hidapi hidapi libusb)"
+}
+
+src_install() {
+       dolib.so "lib/libg810-led.so.${PV}"
+       dosym "libg810-led.so.${PV}" "/usr/$(get_libdir)/libg810-led.so"
+
+       dobin bin/g810-led
+       local boards=(213 410 413 512 513 610 910 pro)
+       local x
+       for x in "${boards[@]}"; do
+               dosym g810-led "/usr/bin/g${x}-led"
+       done
+
+       systemd_dounit systemd/g810-led.service
+       systemd_dounit systemd/g810-led-reboot.service
+
+       udev_newrules udev/g810-led.rules 60-g810-led.rules
+
+       einstalldocs
+}