dev-ruby/json: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sat, 12 Dec 2015 06:51:06 +0000 (07:51 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sat, 12 Dec 2015 07:35:18 +0000 (08:35 +0100)
Package-Manager: portage-2.2.24

dev-ruby/json/Manifest
dev-ruby/json/json-1.8.0.ebuild [deleted file]
dev-ruby/json/json-1.8.2.ebuild [deleted file]

index c360581fc879056df8a522619beb397a1838a460..61fe0cc6d59a8153af14fa2a02371c0f58d0999e 100644 (file)
@@ -1,3 +1,2 @@
-DIST json-1.8.0.gem 148992 SHA256 87e49cccff3fb2091c53141a605956e8d9a252cda43128714f9fdb51d0ca1729 SHA512 7a8ae0d975e10be06d1026df6c9736e8e724814ea7ef8c92b512c60fd7b4ac18e46a9f44615f57407e58decebc4891e2e97b78a177f7e283cc540619264c4400 WHIRLPOOL 159cd8d1cf95d6f7ca5ed16ec294015f873453a1ec8f9eb3667442c0ca582487e5dfcd78d2106c72c5a3563e1ace5b69f2c256c05a35630f09c3499b95f12505
 DIST json-1.8.2.gem 152064 SHA256 256f73d107635f54e3dd84daba65da7b08f9d6a6e6aeb046db6a46b98bd8fb7f SHA512 5c94ec2c5378f7f54cd87a2e265b058e80031d2dd29daf14639c80ba0ac285a527ab7961f5a2cd1e483f455fd8f8c88575950822b7b2d431aa7b2b9c8be819c1 WHIRLPOOL dc17e0c011523434ed29e428a2658ebe58d08df8252e7ee8990882b6d17c19354b3e4ba6985a2a45e4b94932ad265698197ba64ef891f38d3be154da4edde8cb
 DIST json-1.8.3.gem 152064 SHA256 8ca2091e26678fb989d66cdb9f0104f1307bc584b429c2fd783d51e4b3f14bdb SHA512 313f6016aca5eba4d4a14a72b60b3e9c5e863a6681eb9e499cacedb63969694be563990af0a44dae52963f07b6e6c7aa7e0876ab1348b214f53d925bdc5e83ea WHIRLPOOL 8c6dc26a578aedcd4bbc1e6ea95f2a72debe6bdaca5a4c2a4e70b81d9947048c6648b62d5546fa572084d37ba99ce199a177b87838be5cc3f11d8d0fa0f62a63
diff --git a/dev-ruby/json/json-1.8.0.ebuild b/dev-ruby/json/json-1.8.0.ebuild
deleted file mode 100644 (file)
index 879d13d..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
-       dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-all_ruby_prepare() {
-       # Avoid building the extension twice!
-       # And use rdoc instead of sdoc which we don't have packaged
-       # And don't call git to list files. We're using the pregenerated spec anyway.
-       sed -i \
-               -e 's| => :compile||' \
-               -e 's| => :clean||' \
-               -e 's|sdoc|rdoc|' \
-               -e 's|`git ls-files`|""|' \
-               Rakefile || die "rakefile fix failed"
-
-       # Remove hardcoded and broken -O setting.
-       sed -i -e '/^unless/,/^end/ d' -e '/^  (if|unless)/,/^  end/ d' ext/json/ext/*/extconf.rb || die
-}
-
-each_ruby_compile() {
-       # Since 1.5.0 a Java extension is provided but it does not compile.
-       if [[ $(basename ${RUBY}) != "jruby" ]]; then
-               ${RUBY} -S rake compile || die "extension compile failed"
-       fi
-}
-
-each_ruby_test() {
-       JSON=pure \
-       ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
-
-       if [[ $(basename ${RUBY}) != "jruby" ]]; then
-               JSON=ext \
-               ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
-       fi
-}
-
-each_ruby_install() {
-       each_fakegem_install
-       if [[ $(basename ${RUBY}) != "jruby" ]]; then
-               ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
-               ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
-       fi
-}
diff --git a/dev-ruby/json/json-1.8.2.ebuild b/dev-ruby/json/json-1.8.2.ebuild
deleted file mode 100644 (file)
index 5cdc5aa..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="https://github.com/flori/json"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
-       dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-all_ruby_prepare() {
-       # Avoid building the extension twice!
-       # And use rdoc instead of sdoc which we don't have packaged
-       # And don't call git to list files. We're using the pregenerated spec anyway.
-       sed -i \
-               -e 's| => :compile||' \
-               -e 's| => :clean||' \
-               -e 's|sdoc|rdoc|' \
-               -e 's|`git ls-files`|""|' \
-               Rakefile || die "rakefile fix failed"
-
-       # Remove hardcoded and broken -O setting.
-       sed -i -e '/^  \(if\|unless\)/,/^  end/ s:^:#:' \
-               -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
-}
-
-each_ruby_compile() {
-       # Since 1.5.0 a Java extension is provided but it does not compile.
-       if [[ $(basename ${RUBY}) != "jruby" ]]; then
-               ${RUBY} -S rake compile || die "extension compile failed"
-       fi
-}
-
-each_ruby_test() {
-       JSON=pure \
-       ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
-
-       if [[ $(basename ${RUBY}) != "jruby" ]]; then
-               JSON=ext \
-               ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
-       fi
-}
-
-each_ruby_install() {
-       each_fakegem_install
-       if [[ $(basename ${RUBY}) != "jruby" ]]; then
-               ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
-               ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
-       fi
-}