dev-python/testrepository: Drop unnecessary die
authorJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:09:34 +0000 (09:09 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:53:18 +0000 (09:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/testrepository/testrepository-0.0.17-r1.ebuild
dev-python/testrepository/testrepository-0.0.17-r2.ebuild
dev-python/testrepository/testrepository-0.0.18-r1.ebuild

index 54eebcdb8cfe403045d28f76cf5cb4b45eb8680d..7f8d670c38168b421b033ecfbf4226dacbf3e6be 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
+
 # Although package supports alt. py impls, only works fully under py2.7
 PYTHON_COMPAT=( python2_7 )
 
@@ -17,18 +18,21 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
 IUSE="test"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-               test? ( dev-python/subunit[${PYTHON_USEDEP}]
-                       >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
-                       dev-python/fixtures[${PYTHON_USEDEP}]
-                       dev-python/testresources[${PYTHON_USEDEP}]
-                       dev-python/testscenarios[${PYTHON_USEDEP}]
-                       dev-python/pytz[${PYTHON_USEDEP}]
-               )"
-#bzr is listed but presumably req'd for a live repo test run
-RDEPEND="dev-python/subunit[${PYTHON_USEDEP}]
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/subunit[${PYTHON_USEDEP}]
                >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
-               dev-python/fixtures[${PYTHON_USEDEP}]"
+               dev-python/fixtures[${PYTHON_USEDEP}]
+               dev-python/testresources[${PYTHON_USEDEP}]
+               dev-python/testscenarios[${PYTHON_USEDEP}]
+               dev-python/pytz[${PYTHON_USEDEP}]
+       )"
+#bzr is listed but presumably req'd for a live repo test run
+RDEPEND="
+       dev-python/subunit[${PYTHON_USEDEP}]
+       >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+       dev-python/fixtures[${PYTHON_USEDEP}]"
 
 python_test() {
        "${PYTHON}" ./testr init || die
index 78b8870e928c0c00f2dcb61dba52230d1f0b6a39..d66490e91c6392e007495416ad3e0b9227069083 100644 (file)
@@ -3,6 +3,7 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python{2_7,3_3} )
 
 inherit distutils-r1
@@ -16,24 +17,26 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
 IUSE="test"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-               test? ( ${RDEPEND}
-                       dev-python/testresources[${PYTHON_USEDEP}]
-                       dev-python/testscenarios[${PYTHON_USEDEP}]
-                       dev-python/pytz[${PYTHON_USEDEP}]
-               )"
 #>=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
 #>=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
 #dev-python/fixtures[${PYTHON_USEDEP}]
 #bzr is listed but presumably req'd for a live repo test run
-RDEPEND=">=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
-               >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
-               dev-python/fixtures[${PYTHON_USEDEP}]"
+RDEPEND="
+       >=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
+       >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+       dev-python/fixtures[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND}
+               dev-python/testresources[${PYTHON_USEDEP}]
+               dev-python/testscenarios[${PYTHON_USEDEP}]
+               dev-python/pytz[${PYTHON_USEDEP}]
+       )"
 
 # Required for test phase
 DISTUTILS_IN_SOURCE_BUILD=1
 
 python_test() {
        "${PYTHON}" ./testr init || die
-       "${PYTHON}" setup.py testr --coverage || die "tests failed under ${EPYTHON}"
+       esetup.py testr --coverage
 }
index f2ea60551810d2921e69f7576df342f1c6d35db1..a5d520941b0495119e8e3c6189242629c6dc1dd8 100644 (file)
@@ -38,5 +38,5 @@ python_test() {
        # some errors appear to have crept in the suite undert py3 since addition.
        # Python2.7 now passes all.
 
-       esetup.py testr --coverage # || die "tests failed under ${EPYTHON}"
+       esetup.py testr --coverage
 }