net-misc/x2goclient: version bump to 0.4.5.2, add qt5 support
authorBernard Cafarelli <voyageur@gentoo.org>
Wed, 28 Sep 2016 20:46:11 +0000 (22:46 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Wed, 28 Sep 2016 20:48:00 +0000 (22:48 +0200)
Thanks kensington for tracking down a resources bundling problem
in the qt5 build:
rcc is the compiled version of qrc, so it looks like for some reason
qmake5 assumes the rcc files are already compiled, and bundles them
as-is instead of processing them

Package-Manager: portage-2.3.1

net-misc/x2goclient/Manifest
net-misc/x2goclient/files/x2goclient-4.0.5.2-rcc_to_qrc.patch [new file with mode: 0644]
net-misc/x2goclient/x2goclient-4.0.5.2.ebuild [new file with mode: 0644]

index fede39f92728417b2bb5dbf699ae2132bc1f8096..89243314aea77603cfc6fad8fca9dcfda0b9a230 100644 (file)
@@ -2,3 +2,4 @@ DIST x2goclient-4.0.3.2.tar.gz 1560536 SHA256 f65a70463eae3d6d9fe6e4379f4ffacda5
 DIST x2goclient-4.0.4.0.tar.gz 1571218 SHA256 86d05ce10039fe0a965cdc55086e00f4f3abc573a96f128b92f87081b7251657 SHA512 53c12e31e9cddc732f1d85f963103c99d3e051946f56b6eef861cb450a5ac69b7d09aceb2a1cb4ff8af949d56abe0c00dff649a1980e21ffbc6980a1a1f87e14 WHIRLPOOL 69bc539e2dd8b4953d3e15417f583d47a4aa6419e207fc6fda666de6b8cf695b85871c3e9995bcfd8cc930bc4b2334d08b1a905a77d5cc97377abde01cbed8bb
 DIST x2goclient-4.0.5.0.tar.gz 1577271 SHA256 242e91720c1e5830f64a632c111ac3c4b6f6690d5005454c8e025b00bfbe42a1 SHA512 4fd3ca6061a4a86d04a699e41b17a546b0ed31e784ff357749d56a8015b60e86d1205580e6e57347a64c6ce47eaa47f054a783c6c90fd6716912333c7858309a WHIRLPOOL 72125958ade3baebdc272621834980ca07290adb16ab3a2129325d7d7ad7692061d5a24c1d48bbcda1c6b925a84bcf97dc30386910d533c0c4ac2db11d0f239f
 DIST x2goclient-4.0.5.1.tar.gz 1657361 SHA256 844e983fbbddfe8a626506e4140b1ad65591e14f794c735412402bee3163ed11 SHA512 29bfd3a1c678b4b36536bfe90ee66007d38fb69d9ef2e4421bc72dd697832e879af5765297a56e18ed05c6fcc1b960115865adb51d838c4e5b083cd9355563b8 WHIRLPOOL f1b1e5e560a7b5684f373180d243e1cc54ca94ce927b987fb5653049fb610e34d4285efeafa57186decc8216058213eff3110ba1e9de96e42d36bb0764ae4e61
+DIST x2goclient-4.0.5.2.tar.gz 1666082 SHA256 0d0adfd5c03cef42367a5894948ee804ae13ffb7ed30a608e7c54351addd1530 SHA512 d1d9eecc17bfeb5067bca32f3fbbe14bcfde8d10f44a3d91cd32edc797371547b9b22adfbcff1f5b33c4869b6d1427424c052cb18e4c91e7905ba22ed2c69c29 WHIRLPOOL d56c9ad8a4e0375f76f4c20f90803c6369f18ada3003fe9d9acde95d7076274fc0e092f88de03a9af95a72039f4951d5f2d36e04b679f432e16bf48f83225319
diff --git a/net-misc/x2goclient/files/x2goclient-4.0.5.2-rcc_to_qrc.patch b/net-misc/x2goclient/files/x2goclient-4.0.5.2-rcc_to_qrc.patch
new file mode 100644 (file)
index 0000000..f055942
--- /dev/null
@@ -0,0 +1,293 @@
+diff -Naur x2goclient-4.0.5.2.orig/res/changelog.qrc x2goclient-4.0.5.2/res/changelog.qrc
+--- x2goclient-4.0.5.2.orig/res/changelog.qrc  1970-01-01 01:00:00.000000000 +0100
++++ x2goclient-4.0.5.2/res/changelog.qrc       2016-09-19 06:17:43.000000000 +0200
+@@ -0,0 +1,5 @@
++<RCC>
++   <qresource>
++       <file>txt/changelog</file>
++   </qresource>
++</RCC>
+diff -Naur x2goclient-4.0.5.2.orig/res/changelog.rcc x2goclient-4.0.5.2/res/changelog.rcc
+--- x2goclient-4.0.5.2.orig/res/changelog.rcc  2016-09-19 06:17:43.000000000 +0200
++++ x2goclient-4.0.5.2/res/changelog.rcc       1970-01-01 01:00:00.000000000 +0100
+@@ -1,5 +0,0 @@
+-<RCC>
+-   <qresource>
+-       <file>txt/changelog</file>
+-   </qresource>
+-</RCC>
+diff -Naur x2goclient-4.0.5.2.orig/res/git.qrc x2goclient-4.0.5.2/res/git.qrc
+--- x2goclient-4.0.5.2.orig/res/git.qrc        1970-01-01 01:00:00.000000000 +0100
++++ x2goclient-4.0.5.2/res/git.qrc     2016-09-19 06:17:43.000000000 +0200
+@@ -0,0 +1,5 @@
++<RCC>
++   <qresource>
++       <file>txt/git-info</file>
++   </qresource>
++</RCC>
+diff -Naur x2goclient-4.0.5.2.orig/res/git.rcc x2goclient-4.0.5.2/res/git.rcc
+--- x2goclient-4.0.5.2.orig/res/git.rcc        2016-09-19 06:17:43.000000000 +0200
++++ x2goclient-4.0.5.2/res/git.rcc     1970-01-01 01:00:00.000000000 +0100
+@@ -1,5 +0,0 @@
+-<RCC>
+-   <qresource>
+-       <file>txt/git-info</file>
+-   </qresource>
+-</RCC>
+diff -Naur x2goclient-4.0.5.2.orig/res/resources.qrc x2goclient-4.0.5.2/res/resources.qrc
+--- x2goclient-4.0.5.2.orig/res/resources.qrc  1970-01-01 01:00:00.000000000 +0100
++++ x2goclient-4.0.5.2/res/resources.qrc       2016-09-19 06:17:44.000000000 +0200
+@@ -0,0 +1,113 @@
++<RCC>
++   <qresource>
++       <file>img/svg/bg.svg</file>
++       <file>img/svg/bg_hildon.svg</file>
++       <file>img/svg/line.svg</file>
++       <file>img/svg/onlogo.svg</file>
++       <file>img/svg/x2gologo.svg</file>
++       <file>img/svg/passform.svg</file>
++       <file>img/svg/sessionbut.svg</file>
++       <file>img/svg/folder.svg</file>
++       <file>img/svg/folder_grey.svg</file>
++       <file>img/svg/sessionbut_grey.svg</file>
++       <file>img/png/ico.png</file>
++       <file>img/png/ico_mini.png</file>
++       <file>img/png/sess_ico.png</file>
++       <file>img/png/ico_440x180.png</file>
++       <file>img/png/power-button.png</file>
++       <file>img/icons/128x128/x2go.png</file>
++       <file>img/icons/128x128/folder.png</file>
++       <file>img/icons/128x128/x2gosession.png</file>
++       <file>img/icons/128x128/create_file.png</file>
++       <file>img/icons/128x128/lxde.png</file>
++       <file>img/icons/128x128/preferences.png</file>
++       <file>img/icons/128x128/rdp.png</file>
++       <file>img/icons/64x64/audio.png</file>
++       <file>img/icons/64x64/personal.png</file>
++       <file>img/icons/64x64/create_file.png</file>
++       <file>img/icons/64x64/lxde.png</file>
++       <file>img/icons/64x64/preferences.png</file>
++       <file>img/icons/64x64/rdp.png</file>
++       <file>img/icons/32x32/edit.png</file>
++       <file>img/icons/32x32/edit_settings.png</file>
++       <file>img/icons/32x32/exit.png</file>
++       <file>img/icons/32x32/file-open.png</file>
++       <file>img/icons/32x32/new_file.png</file>
++       <file>img/icons/32x32/create_file.png</file>
++       <file>img/icons/32x32/lxde.png</file>
++       <file>img/icons/32x32/preferences.png</file>
++       <file>img/icons/32x32/rdp.png</file>
++       <file>img/icons/32x32/reconnect.png</file>
++       <file>img/icons/32x32/tbhide.png</file>
++       <file>img/icons/32x32/tbshow.png</file>
++       <file>img/icons/32x32/attach.png</file>
++       <file>img/icons/32x32/detach.png</file>
++       <file>img/icons/32x32/suspend.png</file>
++       <file>img/icons/32x32/stop.png</file>
++       <file>img/icons/32x32/auth.png</file>
++       <file>img/icons/32x32/x2goclient.png</file>
++       <file>img/icons/32x32/resolution.png</file>
++       <file>img/icons/32x32/contest.png</file>
++       <file>img/icons/32x32/apps.png</file>
++       <file>img/icons/32x32/open_dir.png</file>
++       <file>img/icons/32x32/suspend_session.png</file>
++       <file>img/icons/32x32/stop_session.png</file>
++       <file>img/icons/16x16/audio.png</file>
++       <file>img/icons/16x16/file-open.png</file>
++       <file>img/icons/16x16/delete.png</file>
++       <file>img/icons/16x16/edit.png</file>
++       <file>img/icons/16x16/gnome.png</file>
++       <file>img/icons/16x16/unity.png</file>
++       <file>img/icons/16x16/xfce.png</file>
++       <file>img/icons/16x16/mate.png</file>
++       <file>img/icons/16x16/kde.png</file>
++       <file>img/icons/16x16/cinnamon.png</file>
++       <file>img/icons/16x16/trinity.png</file>
++       <file>img/icons/16x16/openbox.png</file>
++       <file>img/icons/16x16/icewm.png</file>
++       <file>img/icons/16x16/new_file.png</file>
++       <file>img/icons/16x16/resolution.png</file>
++       <file>img/icons/16x16/session.png</file>
++       <file>img/icons/16x16/x2go.png</file>
++       <file>img/icons/16x16/tbshow.png</file>
++       <file>img/icons/16x16/X.png</file>
++       <file>img/icons/16x16/create_file.png</file>
++       <file>img/icons/16x16/lxde.png</file>
++       <file>img/icons/16x16/preferences.png</file>
++       <file>img/icons/16x16/rdp.png</file>
++       <file>img/icons/22x22/applications-development.png</file>
++       <file>img/icons/22x22/applications-education.png</file>
++       <file>img/icons/22x22/applications-games.png</file>
++       <file>img/icons/22x22/applications-graphics.png</file>
++       <file>img/icons/22x22/applications-internet.png</file>
++       <file>img/icons/22x22/applications-multimedia.png</file>
++       <file>img/icons/22x22/applications-office.png</file>
++       <file>img/icons/22x22/applications-other.png</file>
++       <file>img/icons/22x22/applications-system.png</file>
++       <file>img/icons/22x22/applications-utilities.png</file>
++       <file>img/icons/22x22/preferences-system.png</file>
++       <file>txt/packs</file>
++       <file>txt/encodings</file>
++       <file>i18n/x2goclient_da.qm</file>
++       <file>i18n/x2goclient_de.qm</file>
++       <file>i18n/x2goclient_es.qm</file>
++       <file>i18n/x2goclient_et.qm</file>
++       <file>i18n/x2goclient_fi.qm</file>
++       <file>i18n/x2goclient_fr.qm</file>
++       <file>i18n/x2goclient_nb_no.qm</file>
++       <file>i18n/x2goclient_nl.qm</file>
++       <file>i18n/x2goclient_pt.qm</file>
++       <file>i18n/x2goclient_ru.qm</file>
++       <file>i18n/x2goclient_sv.qm</file>
++       <file>i18n/x2goclient_tr.qm</file>
++       <file>i18n/x2goclient_zh_tw.qm</file>
++       <file>i18n/qt_da.qm</file>
++       <file>i18n/qt_de.qm</file>
++       <file>i18n/qt_es.qm</file>
++       <file>i18n/qt_fr.qm</file>
++       <file>i18n/qt_pt.qm</file>
++       <file>i18n/qt_ru.qm</file>
++       <file>i18n/qt_sv.qm</file>
++       <file>i18n/qt_zh_tw.qm</file>
++   </qresource>
++</RCC>
+diff -Naur x2goclient-4.0.5.2.orig/res/resources.rcc x2goclient-4.0.5.2/res/resources.rcc
+--- x2goclient-4.0.5.2.orig/res/resources.rcc  2016-09-19 06:17:44.000000000 +0200
++++ x2goclient-4.0.5.2/res/resources.rcc       1970-01-01 01:00:00.000000000 +0100
+@@ -1,113 +0,0 @@
+-<RCC>
+-   <qresource>
+-       <file>img/svg/bg.svg</file>
+-       <file>img/svg/bg_hildon.svg</file>
+-       <file>img/svg/line.svg</file>
+-       <file>img/svg/onlogo.svg</file>
+-       <file>img/svg/x2gologo.svg</file>
+-       <file>img/svg/passform.svg</file>
+-       <file>img/svg/sessionbut.svg</file>
+-       <file>img/svg/folder.svg</file>
+-       <file>img/svg/folder_grey.svg</file>
+-       <file>img/svg/sessionbut_grey.svg</file>
+-       <file>img/png/ico.png</file>
+-       <file>img/png/ico_mini.png</file>
+-       <file>img/png/sess_ico.png</file>
+-       <file>img/png/ico_440x180.png</file>
+-       <file>img/png/power-button.png</file>
+-       <file>img/icons/128x128/x2go.png</file>
+-       <file>img/icons/128x128/folder.png</file>
+-       <file>img/icons/128x128/x2gosession.png</file>
+-       <file>img/icons/128x128/create_file.png</file>
+-       <file>img/icons/128x128/lxde.png</file>
+-       <file>img/icons/128x128/preferences.png</file>
+-       <file>img/icons/128x128/rdp.png</file>
+-       <file>img/icons/64x64/audio.png</file>
+-       <file>img/icons/64x64/personal.png</file>
+-       <file>img/icons/64x64/create_file.png</file>
+-       <file>img/icons/64x64/lxde.png</file>
+-       <file>img/icons/64x64/preferences.png</file>
+-       <file>img/icons/64x64/rdp.png</file>
+-       <file>img/icons/32x32/edit.png</file>
+-       <file>img/icons/32x32/edit_settings.png</file>
+-       <file>img/icons/32x32/exit.png</file>
+-       <file>img/icons/32x32/file-open.png</file>
+-       <file>img/icons/32x32/new_file.png</file>
+-       <file>img/icons/32x32/create_file.png</file>
+-       <file>img/icons/32x32/lxde.png</file>
+-       <file>img/icons/32x32/preferences.png</file>
+-       <file>img/icons/32x32/rdp.png</file>
+-       <file>img/icons/32x32/reconnect.png</file>
+-       <file>img/icons/32x32/tbhide.png</file>
+-       <file>img/icons/32x32/tbshow.png</file>
+-       <file>img/icons/32x32/attach.png</file>
+-       <file>img/icons/32x32/detach.png</file>
+-       <file>img/icons/32x32/suspend.png</file>
+-       <file>img/icons/32x32/stop.png</file>
+-       <file>img/icons/32x32/auth.png</file>
+-       <file>img/icons/32x32/x2goclient.png</file>
+-       <file>img/icons/32x32/resolution.png</file>
+-       <file>img/icons/32x32/contest.png</file>
+-       <file>img/icons/32x32/apps.png</file>
+-       <file>img/icons/32x32/open_dir.png</file>
+-       <file>img/icons/32x32/suspend_session.png</file>
+-       <file>img/icons/32x32/stop_session.png</file>
+-       <file>img/icons/16x16/audio.png</file>
+-       <file>img/icons/16x16/file-open.png</file>
+-       <file>img/icons/16x16/delete.png</file>
+-       <file>img/icons/16x16/edit.png</file>
+-       <file>img/icons/16x16/gnome.png</file>
+-       <file>img/icons/16x16/unity.png</file>
+-       <file>img/icons/16x16/xfce.png</file>
+-       <file>img/icons/16x16/mate.png</file>
+-       <file>img/icons/16x16/kde.png</file>
+-       <file>img/icons/16x16/cinnamon.png</file>
+-       <file>img/icons/16x16/trinity.png</file>
+-       <file>img/icons/16x16/openbox.png</file>
+-       <file>img/icons/16x16/icewm.png</file>
+-       <file>img/icons/16x16/new_file.png</file>
+-       <file>img/icons/16x16/resolution.png</file>
+-       <file>img/icons/16x16/session.png</file>
+-       <file>img/icons/16x16/x2go.png</file>
+-       <file>img/icons/16x16/tbshow.png</file>
+-       <file>img/icons/16x16/X.png</file>
+-       <file>img/icons/16x16/create_file.png</file>
+-       <file>img/icons/16x16/lxde.png</file>
+-       <file>img/icons/16x16/preferences.png</file>
+-       <file>img/icons/16x16/rdp.png</file>
+-       <file>img/icons/22x22/applications-development.png</file>
+-       <file>img/icons/22x22/applications-education.png</file>
+-       <file>img/icons/22x22/applications-games.png</file>
+-       <file>img/icons/22x22/applications-graphics.png</file>
+-       <file>img/icons/22x22/applications-internet.png</file>
+-       <file>img/icons/22x22/applications-multimedia.png</file>
+-       <file>img/icons/22x22/applications-office.png</file>
+-       <file>img/icons/22x22/applications-other.png</file>
+-       <file>img/icons/22x22/applications-system.png</file>
+-       <file>img/icons/22x22/applications-utilities.png</file>
+-       <file>img/icons/22x22/preferences-system.png</file>
+-       <file>txt/packs</file>
+-       <file>txt/encodings</file>
+-       <file>i18n/x2goclient_da.qm</file>
+-       <file>i18n/x2goclient_de.qm</file>
+-       <file>i18n/x2goclient_es.qm</file>
+-       <file>i18n/x2goclient_et.qm</file>
+-       <file>i18n/x2goclient_fi.qm</file>
+-       <file>i18n/x2goclient_fr.qm</file>
+-       <file>i18n/x2goclient_nb_no.qm</file>
+-       <file>i18n/x2goclient_nl.qm</file>
+-       <file>i18n/x2goclient_pt.qm</file>
+-       <file>i18n/x2goclient_ru.qm</file>
+-       <file>i18n/x2goclient_sv.qm</file>
+-       <file>i18n/x2goclient_tr.qm</file>
+-       <file>i18n/x2goclient_zh_tw.qm</file>
+-       <file>i18n/qt_da.qm</file>
+-       <file>i18n/qt_de.qm</file>
+-       <file>i18n/qt_es.qm</file>
+-       <file>i18n/qt_fr.qm</file>
+-       <file>i18n/qt_pt.qm</file>
+-       <file>i18n/qt_ru.qm</file>
+-       <file>i18n/qt_sv.qm</file>
+-       <file>i18n/qt_zh_tw.qm</file>
+-   </qresource>
+-</RCC>
+diff -Naur x2goclient-4.0.5.2.orig/x2goclient.pro x2goclient-4.0.5.2/x2goclient.pro
+--- x2goclient-4.0.5.2.orig/x2goclient.pro     2016-09-19 06:17:44.000000000 +0200
++++ x2goclient-4.0.5.2/x2goclient.pro  2016-09-28 22:03:41.830790244 +0200
+@@ -167,16 +167,16 @@
+ TEMPLATE = app
+ DEPENDPATH += .
+ INCLUDEPATH += src
+-RESOURCES += res/resources.rcc
++RESOURCES += res/resources.qrc
+ exists(res/txt/git-info) {
+   message("Configuring with --git-info")
+-  RESOURCES += res/git.rcc
++  RESOURCES += res/git.qrc
+ }
+ exists(res/txt/changelog) {
+   message("Configuring with --changelog")
+-  RESOURCES += res/changelog.rcc
++  RESOURCES += res/changelog.qrc
+ }
+ linux-g++ {
diff --git a/net-misc/x2goclient/x2goclient-4.0.5.2.ebuild b/net-misc/x2goclient/x2goclient-4.0.5.2.ebuild
new file mode 100644 (file)
index 0000000..52527c8
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit nsplugins qmake-utils
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin +qt4 qt5"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+       net-print/cups
+       x11-libs/libXpm
+       ldap? ( net-nds/openldap )
+       qt4? (
+               dev-qt/qtcore:4[ssl]
+               dev-qt/qtgui:4
+               dev-qt/qtsvg:4
+       )
+       qt5? (
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtnetwork:5[ssl]
+               dev-qt/qtsvg:5
+               dev-qt/qtwidgets:5
+               dev-qt/qtx11extras:5
+       )"
+
+RDEPEND="${DEPEND}
+       net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+PATCHES=( "${FILESDIR}"/${P}-rcc_to_qrc.patch )
+
+src_prepare() {
+       if ! use ldap; then
+               sed -e "s/-lldap//" -i x2goclient.pro || die
+               sed -e "s/#define USELDAP//" -i src/x2goclientconfig.h || die
+       fi
+
+       mkdir -p "${CLIENT_BUILD}"
+       use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+
+       default
+}
+
+src_configure() {
+       local EQMAKE
+       use qt4 && EQMAKE=eqmake4
+       use qt5 && EQMAKE=eqmake5
+
+       cd "${CLIENT_BUILD}"
+       ${EQMAKE} "${S}"/x2goclient.pro
+
+       if use nsplugin;
+       then
+               cd "${PLUGIN_BUILD}"
+               X2GO_CLIENT_TARGET=plugin ${EQMAKE} "${S}"/x2goclient.pro
+       fi
+}
+
+src_compile() {
+       cd "${CLIENT_BUILD}"
+       emake
+
+       if use nsplugin;
+       then
+               cd "${PLUGIN_BUILD}"
+               emake
+       fi
+}
+
+src_install() {
+       dobin "${CLIENT_BUILD}"/${PN}
+
+       insinto /usr/share/pixmaps/x2goclient
+       doins res/img/icons/${PN}.xpm
+
+       domenu desktop/${PN}.desktop
+       doman man/man?/*
+
+       if use nsplugin;
+       then
+               # PLUGINS_DIR comes from nsplugins.eclass
+               exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+               doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+       fi
+
+       emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}