x11-misc/grsync: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Thu, 27 Feb 2020 10:38:18 +0000 (11:38 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Thu, 27 Feb 2020 10:44:03 +0000 (11:44 +0100)
Closes: https://bugs.gentoo.org/710874
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-misc/grsync/files/grsync-1.2.6-gcc-10.patch [new file with mode: 0644]
x11-misc/grsync/grsync-1.2.6.ebuild

diff --git a/x11-misc/grsync/files/grsync-1.2.6-gcc-10.patch b/x11-misc/grsync/files/grsync-1.2.6-gcc-10.patch
new file mode 100644 (file)
index 0000000..4460f1a
--- /dev/null
@@ -0,0 +1,36 @@
+diff -Naur grsync-1.2.6.orig/src/callbacks.h grsync-1.2.6/src/callbacks.h
+--- grsync-1.2.6.orig/src/callbacks.h  2013-04-30 13:48:54.000000000 +0200
++++ grsync-1.2.6/src/callbacks.h       2020-02-27 11:34:50.861824303 +0100
+@@ -7,11 +7,11 @@
+ #define ICON_PACKAGE PACKAGE_DATA_DIR "/" ICON_SOURCE
+ #define ICON_PACKAGE_BUSY PACKAGE_DATA_DIR "/" ICON_SOURCE_BUSY
+-GtkBuilder *builder;
+-GtkWidget *main_window;
+-gchar *argv_session, *argv_filename, *icon, *icon_busy;
+-gboolean cmdline_session, cmdline_execute, cmdline_stayopen, cmdline_import;
+-GtkListStore *liststore_session;
++extern GtkBuilder *builder;
++extern GtkWidget *main_window;
++extern gchar *argv_session, *argv_filename, *icon, *icon_busy;
++extern gboolean cmdline_session, cmdline_execute, cmdline_stayopen, cmdline_import;
++extern GtkListStore *liststore_session;
+ void save_settings(gchar *session, gchar *filename);
+ gboolean load_groups(gchar *session);
+diff -Naur grsync-1.2.6.orig/src/main.c grsync-1.2.6/src/main.c
+--- grsync-1.2.6.orig/src/main.c       2013-04-30 13:48:54.000000000 +0200
++++ grsync-1.2.6/src/main.c    2020-02-27 11:35:08.548834429 +0100
+@@ -10,6 +10,12 @@
+ #     include <libosso.h>
+ #endif
++GtkBuilder *builder;
++GtkWidget *main_window;
++gchar *argv_session, *argv_filename, *icon, *icon_busy;
++gboolean cmdline_session, cmdline_execute, cmdline_stayopen, cmdline_import;
++GtkListStore *liststore_session;
++
+ int main (int argc, char *argv[]) {
+ #ifdef ENABLE_NLS
+       bindtextdomain(GETTEXT_PACKAGE, PACKAGE_LOCALE_DIR);
index 4115d15bc3b3204691b50d5492fb66030c107796..53875ffebdacb9b71adbb3118570d0a985849beb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -19,6 +19,8 @@ DEPEND="${RDEPEND}
 
 DOCS="AUTHORS NEWS README"
 
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
+
 src_configure() {
        econf --disable-unity
 }