sys-libs/kpmcore: bump version to 4.0.0
authorAndrius Štikonas <andrius@stikonas.eu>
Thu, 2 May 2019 19:39:46 +0000 (20:39 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 8 May 2019 17:03:15 +0000 (19:03 +0200)
Signed-off-by: Andrius Štikonas <andrius@stikonas.eu>
Closes: https://github.com/gentoo/kde/pull/879
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-libs/kpmcore/Manifest
sys-libs/kpmcore/kpmcore-4.0.0.ebuild [new file with mode: 0644]

index dedbd7747bb33f04cf7ce9cd2bcd178a8a566fa7..faa8fd124325cc4874296cccab17eafa18b8fa12 100644 (file)
@@ -1 +1,2 @@
 DIST kpmcore-3.3.0.tar.xz 412648 BLAKE2B c8e5bf8d20108b8c3164466bf4b08ec9e58808a20134e27b188f0b85809bf1dffabe293f7b1f53d96a6291d4a5d9c1945a496763aa5f72eaccde83f4fcc62c8b SHA512 62a0a341fbbec426291e2c9dd183a20466fce48ffaa360dd816c58402ee03c1f61c4ef7887d0a66c4693d77c2183a5da3477b828ba4ac2ed405f684ffb27125e
+DIST kpmcore-4.0.0.tar.xz 417784 BLAKE2B deffb82b3ec5029ce845a398728b31b4da1b1b69377684a982b0d8067cfddc9ccb2ab2f4369faeb289b4aa54841940aae5a69051a30e4895b840c51393b0c487 SHA512 16f0a8ecae35c214272f28c49b5fff3d2d5e0959b9dceba392b9b6186d44e10d11fcf16ef0ad1da42f49f0c631ccb858d726a92d7c2f22125dae07fd4d2c5500
diff --git a/sys-libs/kpmcore/kpmcore-4.0.0.ebuild b/sys-libs/kpmcore/kpmcore-4.0.0.ebuild
new file mode 100644 (file)
index 0000000..9bdc18d
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FRAMEWORKS_MINIMAL="5.56"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+       SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://kde.org/applications/system/kdepartitionmanager"
+LICENSE="GPL-3"
+SLOT="5/8"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+       $(add_frameworks_dep kauth)
+       $(add_frameworks_dep kcoreaddons)
+       $(add_frameworks_dep ki18n)
+       $(add_frameworks_dep kwidgetsaddons)
+       $(add_qt_dep qtdbus)
+       $(add_qt_dep qtgui)
+       $(add_qt_dep qtwidgets)
+       || (
+               app-crypt/qca[botan]
+               app-crypt/qca[ssl]
+       )
+       >=sys-apps/util-linux-2.33.2
+"
+RDEPEND="${DEPEND}"