dev-vcs/mercurial: Make CFLAGS local before modification
authorCédric Krier <cedk@gentoo.org>
Sun, 26 Jan 2020 09:54:57 +0000 (10:54 +0100)
committerCédric Krier <cedk@gentoo.org>
Sun, 26 Jan 2020 09:55:17 +0000 (10:55 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Cédric Krier <cedk@gentoo.org>
dev-vcs/mercurial/mercurial-5.2.2.ebuild

index 339f1ec904c2f58a6992a9b7f5e6ed536fb6322c..e189226b04d1ddaa12619bbca2bddd0f0f53b4bf 100644 (file)
@@ -53,7 +53,7 @@ python_prepare_all() {
 
 python_compile() {
        strip-flags -ftracer -ftree-vectorize
-       python_is_python3 || append-flags -fno-strict-aliasing
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile build_ext --no-zstd
 }