dev-python/hypothesis: Bump to 4.44.2
authorMichał Górny <mgorny@gentoo.org>
Fri, 15 Nov 2019 08:55:44 +0000 (09:55 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 15 Nov 2019 08:59:56 +0000 (09:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-4.44.2.ebuild [new file with mode: 0644]

index 229227db266296a87dc1c95da74de7a742b589e8..ada7f15f74a683f9c635652fd332661c6d4cb31e 100644 (file)
@@ -4,3 +4,4 @@ DIST hypothesis-python-3.74.3.tar.gz 552616 BLAKE2B e19a0991e7ae2fa6208c81d336cc
 DIST hypothesis-python-3.83.1.tar.gz 564466 BLAKE2B 7b4c00a46b5a547bfc98711b795525c09d91ed41ac2c1dcf9c3c571e32819c77c6f6a4311ff32020a6d8e837dfcd03f7e2d842613148201d476615831483a737 SHA512 d828dbfe8637b6388b8c77af08970c2b45cd8f6960f26b1c54f3fbeba012e225d116802cae70ee28321de9d961397e60a5ff8cbefc02d085b6f6978f6bddf56e
 DIST hypothesis-python-3.85.1.tar.gz 568995 BLAKE2B 65297e73ec833beee05f7ad4f137cdbfe1b28cc478df31fedf8fc2c5183e70c10d5254fdba906842551fcfb7280ac59b3a7dc5cf752700c770c90d158cb81324 SHA512 cf6951d8cb70539b57147f422e43296518edf416200eec220f0c3f258ee6215f858e496f66b340ea68d1754cd936fc26a4ce4d1ee7a38cf338398d316c06cc24
 DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad2582eb23bd8ab2e218f1bde82ba1639123f32e8c147313c22b15781d8986574813b5f6eb7c23ce28367e86bb304d33a23f179fa0 SHA512 7d9788b351196fc20e66e210b7d60b4ddb1507b85cf5a29de228600e07f676ccd1352f5d2ab0820b3c8c1a1e8ff145225f00a25aec5f325cc7405ffd0dfcd9f7
+DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d91eda525f8ef51eb893f1f8e5224cead8572f3c06f6a4bb345c123e56ed06d0676c85dc4477a80e54480baa6bd9f5f2bc069e SHA512 bebc5da337fa74a75d08cb57531c2f6b8ba1ab16d1a3d9be8348cd56ada1ab25a34e3b812a4aa71bf172bc97ebc8df0accdad37466f9162c3f8f2a8edbea9da9
diff --git a/dev-python/hypothesis/hypothesis-4.44.2.ebuild b/dev-python/hypothesis/hypothesis-4.44.2.ebuild
new file mode 100644 (file)
index 0000000..4d3e972
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/flaky[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+               dev-python/pytest-xdist[${PYTHON_USEDEP}]
+       )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+python_test() {
+       py.test -v tests/cover/test_testdecorators.py || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       optfeature "datetime support" dev-python/pytz
+       optfeature "dateutil support" dev-python/python-dateutil
+       optfeature "numpy support" dev-python/numpy
+       optfeature "django support" dev-python/django dev-python/pytz
+       optfeature "pandas support" dev-python/pandas
+       optfeature "pytest support" dev-python/pytest
+}