sys-fs/lvm2: use /bin/bash as CONFIG_SHELL
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 24 Jul 2019 10:06:20 +0000 (12:06 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 24 Jul 2019 10:06:20 +0000 (12:06 +0200)
Closes: https://bugs.gentoo.org/682404
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-fs/lvm2/lvm2-2.02.183.ebuild
sys-fs/lvm2/lvm2-2.02.184-r4.ebuild
sys-fs/lvm2/lvm2-2.02.185.ebuild
sys-fs/lvm2/lvm2-2.03.05.ebuild

index 1b37eab4af348f2287b6664d506666283dca3339..595dd187372a8fbfb11f4d4a6bfb2dab89e2bf88 100644 (file)
@@ -180,6 +180,9 @@ src_configure() {
                --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
                CLDFLAGS="${LDFLAGS}"
        )
+       # Hard-wire this to bash as some shells (dash) don't know
+       # "-o pipefail" #682404
+       CONFIG_SHELL="/bin/bash" \
        econf "${myeconfargs[@]}"
 }
 
index 30771d99b7c723881feffb8d9dcb20b00c978f38..bfe82c27d5d0933d68b7048718759156a85052dc 100644 (file)
@@ -185,6 +185,9 @@ src_configure() {
                --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
                CLDFLAGS="${LDFLAGS}"
        )
+       # Hard-wire this to bash as some shells (dash) don't know
+       # "-o pipefail" #682404
+       CONFIG_SHELL="/bin/bash" \
        econf "${myeconfargs[@]}"
 }
 
index 2912f4832990b7123d07bc06c1bdd252fc8da79a..812f84d2b656dfade3ef8de7a58c397bb0f8a65c 100644 (file)
@@ -188,6 +188,9 @@ src_configure() {
                --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
                CLDFLAGS="${LDFLAGS}"
        )
+       # Hard-wire this to bash as some shells (dash) don't know
+       # "-o pipefail" #682404
+       CONFIG_SHELL="/bin/bash" \
        econf "${myeconfargs[@]}"
 }
 
index d4cb83b032c7c4ec5544437336aa9a7e87ef7ed8..12b13a5e36e6e784ce0a7e6ba7ae3c0f318286ca 100644 (file)
@@ -177,6 +177,9 @@ src_configure() {
                --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
                CLDFLAGS="${LDFLAGS}"
        )
+       # Hard-wire this to bash as some shells (dash) don't know
+       # "-o pipefail" #682404
+       CONFIG_SHELL="/bin/bash" \
        econf "${myeconfargs[@]}"
 }