dev-python/strict-rfc3339: New package, ebuild written by me
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 10:31:00 +0000 (12:31 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 11:05:31 +0000 (13:05 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/strict-rfc3339/Manifest [new file with mode: 0644]
dev-python/strict-rfc3339/metadata.xml [new file with mode: 0644]
dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild [new file with mode: 0644]

diff --git a/dev-python/strict-rfc3339/Manifest b/dev-python/strict-rfc3339/Manifest
new file mode 100644 (file)
index 0000000..a1624c8
--- /dev/null
@@ -0,0 +1 @@
+DIST strict-rfc3339-0.6.tar.gz 16856 SHA256 8d505093cff2a65144eecee09a171ec3401a4d725438381c22011eceddf549df SHA512 7f1e15d60c2295c00647af84b31a1836b6c3994fadbb2695f5709861caae543ae69a3199dffd6dcf7e0768eadf39e496a5e600e291dd0befbe8fc35fa60897af WHIRLPOOL 39f6c8ba67bf84d9c208ae96c32fe25d85a8043d55474994372fe68ed0d6e7254db89df956204c606e950d9d35fd1896c18b65a81d980aafc873da010ff710e8
diff --git a/dev-python/strict-rfc3339/metadata.xml b/dev-python/strict-rfc3339/metadata.xml
new file mode 100644 (file)
index 0000000..301d220
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild b/dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild
new file mode 100644 (file)
index 0000000..2abdefb
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Strict, simple, lightweight RFC3339 functions"
+HOMEPAGE="https://pypi.python.org/pypi/strict-rfc3339 https://github.com/danielrichman/strict-rfc3339"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""