dev-python/toml: Handle missing numpy gracefully
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 14:43:37 +0000 (16:43 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 16:16:26 +0000 (18:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/toml/files/toml-0.10.1-skip-numpy.patch [new file with mode: 0644]
dev-python/toml/toml-0.10.1.ebuild

diff --git a/dev-python/toml/files/toml-0.10.1-skip-numpy.patch b/dev-python/toml/files/toml-0.10.1-skip-numpy.patch
new file mode 100644 (file)
index 0000000..5c6808d
--- /dev/null
@@ -0,0 +1,37 @@
+From 93901215b45db2ab9d50987ac109c29acbe34600 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 25 May 2020 16:38:17 +0200
+Subject: [PATCH] Skip numpy tests when numpy is not available
+
+Make it possible to successfully run tests without numpy installed.
+This package is becoming quite hard profile, and being able to test it
+without building numpy first would be a nice feature.
+---
+ tests/test_api.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_api.py b/tests/test_api.py
+index dd12eb3..67bcd88 100644
+--- a/tests/test_api.py
++++ b/tests/test_api.py
+@@ -103,7 +103,7 @@ def test_array_sep():
+ def test_numpy_floats():
+-    import numpy as np
++    np = pytest.importorskip('numpy')
+     encoder = toml.TomlNumpyEncoder()
+     d = {'a': np.array([1, .3], dtype=np.float64)}
+@@ -120,7 +120,7 @@ def test_numpy_floats():
+ def test_numpy_ints():
+-    import numpy as np
++    np = pytest.importorskip('numpy')
+     encoder = toml.TomlNumpyEncoder()
+     d = {'a': np.array([1, 3], dtype=np.int64)}
+-- 
+2.26.2
+
index 2dc1660a0caeb6786c8f68aec8301aa5190f14fc..e0c1f393ad3314b2cc4e6e8c89abdc84a669c0a9 100644 (file)
@@ -23,6 +23,9 @@ BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*') )"
 
 DOCS=( README.rst )
+PATCHES=(
+       "${FILESDIR}"/toml-0.10.1-skip-numpy.patch
+)
 
 distutils_enable_tests pytest