dev-python/defusedxml: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:07 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:07 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/defusedxml/defusedxml-0.5.0.ebuild

index 64ed2fda15264f712d173e188b4ced4d828fd4ce..bb5c513d3b5750abb131f107ab8c40282513fee1 100644 (file)
@@ -24,6 +24,11 @@ python_test() {
 }
 
 python_install_all() {
-       use examples && local EXAMPLES=( other/. )
+       if use examples; then
+               docinto examples
+               dodoc -r other/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install_all
 }