dev-python/sphinx: Remove implicit dep on sphinx_rtd_theme
authorMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 06:23:45 +0000 (08:23 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 08:15:29 +0000 (10:15 +0200)
Sphinx does not require this theme in any way, it merely has a special
internal function to load it.  Same holds for alabaster, though I guess
that dependency makes sense since it's the default theme.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx/sphinx-1.7.5-r2.ebuild [moved from dev-python/sphinx/sphinx-1.7.5-r1.ebuild with 96% similarity]
dev-python/sphinx/sphinx-2.0.1-r1.ebuild
dev-python/sphinx/sphinx-2.4.3-r1.ebuild
dev-python/sphinx/sphinx-2.4.4.ebuild
dev-python/sphinx/sphinx-3.0.0.ebuild
dev-python/sphinx/sphinx-3.0.1.ebuild
dev-python/sphinx/sphinx-3.0.2-r1.ebuild [moved from dev-python/sphinx/sphinx-3.0.2.ebuild with 98% similarity]

similarity index 96%
rename from dev-python/sphinx/sphinx-1.7.5-r1.ebuild
rename to dev-python/sphinx/sphinx-1.7.5-r2.ebuild
index 1fa175f98d3a2c6717c44ba3905d414eb7c65df6..1f2aa22be731574c795d3d82ee055502447adc5f 100644 (file)
@@ -32,8 +32,6 @@ RDEPEND="
        >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
        >=dev-python/six-1.5[${PYTHON_USEDEP}]
        >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
-       >=dev-python/sphinx_rtd_theme-0.1[${PYTHON_USEDEP}]
-       <dev-python/sphinx_rtd_theme-2.0[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
        $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' -2)
index e3f1dcf723701cf67ffcf585761e59fe3e4715b6..5f5a93b9fe460805c20f7b4517e8b19c1af0c956 100644 (file)
@@ -36,7 +36,6 @@ RDEPEND="
        dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
-       dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
        latex? (
                dev-texlive/texlive-latexextra
index f237709f572ac3c049c152b7bd208a963fd09c05..b921c1a7ab4541b56ab91e17418a27305ce4d148 100644 (file)
@@ -35,7 +35,6 @@ RDEPEND="
        dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
-       dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '
                dev-python/typed-ast[${PYTHON_USEDEP}]
index 88db1c4f032354ae6ef363259f9590e7803423b5..d2610f3a6fa4d23f02cb55afe887044123a77a9a 100644 (file)
@@ -35,7 +35,6 @@ RDEPEND="
        dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
-       dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '
                dev-python/typed-ast[${PYTHON_USEDEP}]
index 1a71657e28638d6d29d4c3d34df5ce03cf561b48..1b53e6155e76a21a18238c0595052d72b7f6f694 100644 (file)
@@ -35,7 +35,6 @@ RDEPEND="
        dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
-       dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '
                dev-python/typed-ast[${PYTHON_USEDEP}]
index cc3f58c1fc5014d56c23e5a382c31a9752e22eea..ea19d76fea3f3962607daeee6fdeeb4b15e1be02 100644 (file)
@@ -35,7 +35,6 @@ RDEPEND="
        dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
-       dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '
                dev-python/typed-ast[${PYTHON_USEDEP}]
similarity index 98%
rename from dev-python/sphinx/sphinx-3.0.2.ebuild
rename to dev-python/sphinx/sphinx-3.0.2-r1.ebuild
index cc3f58c1fc5014d56c23e5a382c31a9752e22eea..ea19d76fea3f3962607daeee6fdeeb4b15e1be02 100644 (file)
@@ -35,7 +35,6 @@ RDEPEND="
        dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
        dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
-       dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '
                dev-python/typed-ast[${PYTHON_USEDEP}]