dev-libs/libixion: Update live ebuild
authorNils Freydank <holgersson@posteo.de>
Mon, 2 Mar 2020 22:24:34 +0000 (23:24 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 16 Mar 2020 21:25:43 +0000 (22:25 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Nils Freydank <holgersson@posteo.de>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/libixion/libixion-9999.ebuild

index f52b1d4a22b5b65f62b280c946a776328582b287..741d54be08e41ca6404845399e63261edf47c8d0 100644 (file)
@@ -9,7 +9,7 @@ inherit python-single-r1
 DESCRIPTION="General purpose formula parser & interpreter"
 HOMEPAGE="https://gitlab.com/ixion/ixion"
 
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
        EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
        inherit git-r3 autotools
 else
@@ -38,15 +38,17 @@ pkg_setup() {
 
 src_prepare() {
        default
-       [[ ${PV} == 9999 ]] && eautoreconf
+       [[ ${PV} == *9999 ]] && eautoreconf
 }
 
 src_configure() {
-       econf \
-               $(use_enable debug) \
-               $(use_enable python) \
-               $(use_enable static-libs static) \
+       local myeconfargs=(
+               $(use_enable debug)
+               $(use_enable python)
+               $(use_enable static-libs static)
                $(use_enable threads)
+       )
+       econf "${myeconfargs[@]}"
 }
 
 src_install() {