sys-fs/cryfs: Manually install manpage, don't compress/uncompress
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 16 Jun 2019 18:01:00 +0000 (20:01 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 16 Jun 2019 21:57:05 +0000 (23:57 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-fs/cryfs/cryfs-9999.ebuild

index 0162f8ddc282136ea952a9965e445f7dbc27f57e..a40f623dfb98537eb6e12ea67124de4296179e26 100644 (file)
@@ -39,6 +39,9 @@ DEPEND="${RDEPEND}
 src_prepare() {
        cmake-utils_src_prepare
 
+       # don't install compressed manpage
+       cmake_comment_add_subdirectory doc
+
        # remove tests that require internet access to comply with Gentoo policy
        sed -e "/CurlHttpClientTest.cpp/d" -e "/FakeHttpClientTest.cpp/d" \
                -i test/cpp-utils/CMakeLists.txt || die
@@ -85,7 +88,6 @@ src_install() {
        # work around upstream issue with cmake not creating install target
        # in Makefile if we enable BUILD_TESTING
        dobin "${BUILD_DIR}/src/cryfs-cli/cryfs"
-       gzip -cd "${BUILD_DIR}/doc/cryfs.1.gz" > "${T}/cryfs.1" || die
-       doman "${T}/cryfs.1"
+       doman doc/man/cryfs.1
        einstalldocs
 }