dev-python/ipywidgets: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:12:45 +0000 (13:12 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:12:45 +0000 (13:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/ipywidgets/ipywidgets-7.4.2.ebuild [deleted file]

diff --git a/dev-python/ipywidgets/ipywidgets-7.4.2.ebuild b/dev-python/ipywidgets/ipywidgets-7.4.2.ebuild
deleted file mode 100644 (file)
index 36d3ed7..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="IPython HTML widgets for Jupyter"
-HOMEPAGE="https://ipywidgets.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
-       >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
-       >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
-       >=dev-python/widgetsnbextension-3.0.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-       )
-"
-
-python_test() {
-       nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
-}