dev-cpp/sparsehash: version bump to 2.0.3
authorTim Harder <radhermit@gentoo.org>
Thu, 14 Jan 2016 00:23:40 +0000 (19:23 -0500)
committerTim Harder <radhermit@gentoo.org>
Thu, 14 Jan 2016 00:23:40 +0000 (19:23 -0500)
dev-cpp/sparsehash/Manifest
dev-cpp/sparsehash/metadata.xml
dev-cpp/sparsehash/sparsehash-2.0.3.ebuild [new file with mode: 0644]

index a2c2234f38400146729e3c525defe9c387ab643b..45f0b7f2bcfa56b8b470606d70e9ebf753bb94ee 100644 (file)
@@ -1,2 +1,3 @@
 DIST sparsehash-1.10.tar.gz 289819 SHA256 5a57b77633aab1e59827e51cf6247c4ac521713d45f1764ddba60353cbc9677a SHA512 ecc01e755885b8da5927f4f56c95c02ce9a43e5c0280cdc1cdfa812f787396646925c0f602a35decdf94144e8d2f3ac31b80f5ed98b70ccca607a29bb11f8a35 WHIRLPOOL 643e27499b1981faa7dc8864886c736a5265d78221edaed0fb6bd73eaf943433d5fbe5fe26ec2e52451651e19ce869a6ad08c22d7fb3d71b6cc7bf5866fd3653
 DIST sparsehash-2.0.2.tar.gz 340514 SHA256 2ed639a7155607c097c2029af5f4287296595080b2e5dd2e2ebd9bbb7450b87c SHA512 27d823551bc8364dd3c10f071e51bab55d2bbe9cf74ddb8337d118475aa7fdd38ae07dbb7dbd721c1350830325cadccdadf127f9996f26387e412e108edba3a1 WHIRLPOOL 87d31528bfd7a177c7be3be2bcddf1ba52bcc8791b8b2162cc1902e4cf02695c99b9a6b70fbcfd85d9e03456931bd72fc67b47cad79d0182bd1d4f5eb11e6f0b
+DIST sparsehash-2.0.3.tar.gz 322046 SHA256 05e986a5c7327796dad742182b2d10805a8d4f511ad090da0490f146c1ff7a8c SHA512 bb00d0acb8eba65f7da8015ea4f6bebf8bba36ed6777881960ee215f22b7be17b069c59838d210551ce67a34baccfc7b2fed603677ec53c0c32714d8e76f5d6c WHIRLPOOL e647aed5468c76a40a4cf631cf4fa4a5f312cb4a712eedb5174ac29a59ec018227ca7e8db61e6a77121dc9b1acbe2e52a492fa7ed654d9eb9180237cb1ebdf72
index 3a6027d20c2a56f13bdc68097c36f0504ae402f3..55bed68d5a623bb08544af0eb1aac4a43c4d6679 100644 (file)
@@ -3,7 +3,6 @@
 <pkgmetadata>
        <herd>cpp</herd>
        <upstream>
-               <remote-id type="google-code">google-sparsehash</remote-id>
-               <remote-id type="github">google/sparsehash</remote-id>
+               <remote-id type="github">sparsehash/sparsehash</remote-id>
        </upstream>
 </pkgmetadata>
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild
new file mode 100644 (file)
index 0000000..5fb17a0
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${P}
+
+src_install() {
+       default
+
+       # Installs just every piece
+       rm -rf "${ED}/usr/share/doc"
+       dohtml doc/*
+}