app-shells/heirloom-sh: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 23 Feb 2017 23:51:19 +0000 (00:51 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 24 Feb 2017 22:17:23 +0000 (23:17 +0100)
Package-Manager: portage-2.3.3

app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild [new file with mode: 0644]

diff --git a/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
new file mode 100644 (file)
index 0000000..d745244
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+# slightly broken
+RESTRICT="test"
+
+DESCRIPTION="Heirloom Bourne Shell, derived from OpenSolaris code SVR4/SVID3"
+HOMEPAGE="http://heirloom.sourceforge.net/sh.html"
+SRC_URI="mirror://sourceforge/heirloom/${P}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+       append-cppflags -D_GNU_SOURCE
+       emake \
+               "CFLAGS=${CFLAGS}" \
+               "CPPFLAGS=${CPPFLAGS}" \
+               "LDFLAGS=${LDFLAGS}" \
+               "LARGEF=" \
+               "CC=$(tc-getCC)"
+}
+
+src_install() {
+       exeinto /bin
+       newexe sh jsh
+       newman sh.1 jsh.1
+}