Avoid hardcoded libdir; bug #119140
authorMamoru Komachi <usata@gentoo.org>
Sat, 30 Dec 2006 12:22:08 +0000 (12:22 +0000)
committerMamoru Komachi <usata@gentoo.org>
Sat, 30 Dec 2006 12:22:08 +0000 (12:22 +0000)
Package-Manager: portage-2.1.1-r2

media-libs/vflib/ChangeLog
media-libs/vflib/vflib-3.6.14.ebuild

index 9aad9fd72cc82e24fbdca860cef61b0cbf0fc5f8..d8cebd06a4a2bdf9e53af7e1b39dc3e16e3bd23e 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for media-libs/vflib
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vflib/ChangeLog,v 1.7 2006/11/04 18:06:12 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vflib/ChangeLog,v 1.8 2006/12/30 12:22:08 usata Exp $
+
+  30 Dec 2006; Mamoru KOMACHI <usata@gentoo.org> vflib-3.6.14.ebuild:
+  Avoid hardcoded libdir; bug #119140.
 
 *vflib-3.6.14 (04 Nov 2006)
 
index a9161ac970effb5ace146f1c8facbdaa7d4d8d20..e4cb99110bbf107a08d0e820837e230f655e0bc2 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vflib/vflib-3.6.14.ebuild,v 1.1 2006/11/04 18:06:12 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vflib/vflib-3.6.14.ebuild,v 1.2 2006/12/30 12:22:08 usata Exp $
 
 inherit libtool eutils
 
@@ -53,13 +53,13 @@ src_compile () {
        econf \
                --with-kpathsea \
                --with-kpathsea-include=/usr/include \
-               --with-kpathsea-libdir=/usr/lib \
+               --with-kpathsea-libdir=/usr/$(get_libdir) \
                --with-freetype \
                --with-freetype-includedir=/usr/include/freetype \
-               --with-freetype-libdir=/usr/lib \
+               --with-freetype-libdir=/usr/$(get_libdir) \
                --with-t1lib \
                --with-t1lib-includedir=/usr/include \
-               --with-t1lib-libdir=/usr/lib || die
+               --with-t1lib-libdir=/usr/$(get_libdir) || die
 
        emake -j1 \
                CDEBUGFLAGS="${CFLAGS}" \