sys-auth/keystone: 16.0.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 13 May 2020 21:30:35 +0000 (16:30 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 13 May 2020 21:32:09 +0000 (16:32 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-auth/keystone/Manifest
sys-auth/keystone/keystone-16.0.1.ebuild [new file with mode: 0644]

index 25e01d35833a1bdd73a169e519e53ab0a7326b06..144b6bc5f6a786835e43c1992d7f58116baf2dcd 100644 (file)
@@ -1,3 +1,5 @@
 DIST keystone-16.0.0.tar.gz 1671648 BLAKE2B 172ce385a009c4c5fb83fa6fb7fa06d5be98e72064e21d4b5a62bb61bcbdfdce3702847820b71837ff54077b7b454fc0d2b95eabcbb2150f2919c7f9d3fc7299 SHA512 af4c977c4ef0fdcc89e94929c026daa1175caef96332f9dcb71a559659d8361467b2a40174847a8e7d7b70e1a151002cfe846a1be5fc7c5bfd1a8aeae3975397
+DIST keystone-16.0.1.tar.gz 1683325 BLAKE2B 6f22773592a1c843e82bcded230d2606b7fe8e540d50ccdbd85f53d4e5fda81023e85d04c258bc3741ecd7e4f8855299ab1828c8864862715ffd32629b877245 SHA512 060725244a181a98a3011ef7ae648b67054e64216fc62870b4190fd8475c8c36de01ae6428d1d4fac4bbdb405097aab1a9fe11daa65d4624dc613821cfeee004
 DIST keystone.conf.sample-16.0.0 104552 BLAKE2B 35ec8deb13239ba3d46c5ca78ea41372065a867e2715be3fb17cd43d65f1902f02d79d7bc6c6cb5c6aec19a3833d17e9dda12e8e0605919d3a28b6300d3f2cf3 SHA512 535c47e3ec39d454818c883599cf6fc304044208b71b822bdb67099728306235b2ad06ee60cfce9033375ae7b2338b03a0488267af65e900e80ed68e4fee8c5a
+DIST keystone.conf.sample-16.0.1 104552 BLAKE2B 35ec8deb13239ba3d46c5ca78ea41372065a867e2715be3fb17cd43d65f1902f02d79d7bc6c6cb5c6aec19a3833d17e9dda12e8e0605919d3a28b6300d3f2cf3 SHA512 535c47e3ec39d454818c883599cf6fc304044208b71b822bdb67099728306235b2ad06ee60cfce9033375ae7b2338b03a0488267af65e900e80ed68e4fee8c5a
 DIST keystone.conf.sample-2019.2.9999 104552 BLAKE2B 35ec8deb13239ba3d46c5ca78ea41372065a867e2715be3fb17cd43d65f1902f02d79d7bc6c6cb5c6aec19a3833d17e9dda12e8e0605919d3a28b6300d3f2cf3 SHA512 535c47e3ec39d454818c883599cf6fc304044208b71b822bdb67099728306235b2ad06ee60cfce9033375ae7b2338b03a0488267af65e900e80ed68e4fee8c5a
diff --git a/sys-auth/keystone/keystone-16.0.1.ebuild b/sys-auth/keystone/keystone-16.0.1.ebuild
new file mode 100644 (file)
index 0000000..4494f24
--- /dev/null
@@ -0,0 +1,166 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 user
+
+DESCRIPTION="The Openstack authentication, authorization, and service catalog"
+HOMEPAGE="https://launchpad.net/keystone"
+if [[ ${PV} == *9999 ]];then
+       inherit git-r3
+       SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/train/keystone.conf.sample -> keystone.conf.sample-${PV}"
+       EGIT_REPO_URI="https://github.com/openstack/keystone.git"
+       EGIT_BRANCH="stable/train"
+else
+       SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/train/keystone.conf.sample -> keystone.conf.sample-${PV}
+       https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+sqlite ldap memcached mongo mysql postgres test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+       >=dev-python/flask-1.0.2[${PYTHON_USEDEP}]
+       >=dev-python/flask-restful-0.3.5[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       sqlite? (
+               >=dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}]
+       )
+       mysql? (
+               >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
+               !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
+               >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+       )
+       postgres? (
+               >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
+               >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+       )
+       >=dev-python/sqlalchemy-migrate-0.11.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       >=dev-python/passlib-1.7.0[${PYTHON_USEDEP}]
+       >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+       >=dev-python/keystonemiddleware-7.0.0[${PYTHON_USEDEP}]
+       >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+       >=dev-python/scrypt-0.8.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-cache-1.26.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-context-2.22.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-db-4.27.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-3.44.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-policy-2.3.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+       >=dev-python/oslo-upgradecheck-0.1.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+       >=dev-python/pysaml2-4.5.0[${PYTHON_USEDEP}]
+       >=dev-python/pyjwt-1.6.1[${PYTHON_USEDEP}]
+       >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+       >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/pycadf-1.1.0[${PYTHON_USEDEP}]
+       !~dev-python/pycadf-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/msgpack-0.5.0[${PYTHON_USEDEP}]
+       >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+       memcached? (
+               >=dev-python/python-memcached-1.56[${PYTHON_USEDEP}]
+       )
+       mongo? (
+               >=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
+               !~dev-python/pymongo-3.1[${PYTHON_USEDEP}]
+       )
+       ldap? (
+               >=dev-python/python-ldap-3.1.0[${PYTHON_USEDEP}]
+               >=dev-python/ldappool-2.3.1[${PYTHON_USEDEP}]
+       )
+       || (
+               www-servers/uwsgi[python,${PYTHON_USEDEP}]
+               www-apache/mod_wsgi[${PYTHON_USEDEP}]
+               www-servers/gunicorn[${PYTHON_USEDEP}]
+       )"
+
+#PATCHES=(
+#)
+
+pkg_setup() {
+       enewgroup keystone
+       enewuser keystone -1 -1 /var/lib/keystone keystone
+}
+
+python_prepare_all() {
+       # it's in git, but not in the tarball.....
+       sed -i '/^hacking/d' test-requirements.txt || die
+       mkdir -p ${PN}/tests/tmp/ || die
+       sed -i 's|/usr/local|/usr|g' httpd/keystone-uwsgi-* || die
+       sed -i 's|python|python27|g' httpd/keystone-uwsgi-* || die
+       # allow useage of renamed msgpack
+       sed -i '/^msgpack/d' requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests -I 'test_keystoneclient*' \
+               -e test_static_translated_string_is_Message \
+               -e test_get_token_id_error_handling \
+               -e test_provider_token_expiration_validation \
+               -e test_import --process-restartworker --process-timeout=60 || die "testsuite failed under python2.7"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       diropts -m 0750
+       keepdir /etc/keystone /var/log/keystone
+       insinto /etc/keystone
+       insopts -m0640 -okeystone -gkeystone
+       newins "${DISTDIR}/keystone.conf.sample-${PV}" keystone.conf.sample
+       doins etc/logging.conf.sample
+       doins etc/default_catalog.templates
+#      doins etc/policy.v3cloudsample.json
+       insinto /etc/keystone/httpd
+       doins httpd/*
+
+       fowners keystone:keystone /etc/keystone /etc/keystone/httpd /var/log/keystone
+       # stupid python doing stupid things
+       rm -r "${ED}"/usr/etc
+}
+
+pkg_postinst() {
+       elog "You might want to run:"
+       elog "emerge --config =${CATEGORY}/${PF}"
+       elog "if this is a new install."
+       elog "If you have not already configured your openssl installation"
+       elog "please do it by modifying /etc/ssl/openssl.cnf"
+       elog "BEFORE issuing the configuration command."
+       elog "Otherwise default values will be used."
+}
+
+pkg_config() {
+       if [ ! -d "${ROOT}"/etc/keystone/ssl ] ; then
+               einfo "Press ENTER to configure the keystone PKI, or Control-C to abort now..."
+               read
+               "${ROOT}"/usr/bin/keystone-manage pki_setup --keystone-user keystone --keystone-group keystone
+       else
+               einfo "keystone PKI certificates directory already present, skipping configuration"
+       fi
+}