sys-power/acpi_call: support kernel 5.6
authorJason A. Donenfeld <zx2c4@gentoo.org>
Sun, 8 Mar 2020 05:06:47 +0000 (13:06 +0800)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Sun, 8 Mar 2020 05:07:38 +0000 (13:07 +0800)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
sys-power/acpi_call/acpi_call-3.17.ebuild
sys-power/acpi_call/files/acpi_call-3.17-linux-5.6.patch [new file with mode: 0644]

index 186d45388dc7f4652d7b887b856fe98dd1d6b89c..62437ef109750f22082bb517e23f4abdbc3646dd 100644 (file)
@@ -29,6 +29,7 @@ BUILD_TARGETS="default"
 PATCHES=(
        "${FILESDIR}/${P}-linux-4.12.patch"
        "${FILESDIR}/${P}-linux-4.14.patch"
+       "${FILESDIR}/${P}-linux-5.6.patch"
 )
 
 src_compile() {
diff --git a/sys-power/acpi_call/files/acpi_call-3.17-linux-5.6.patch b/sys-power/acpi_call/files/acpi_call-3.17-linux-5.6.patch
new file mode 100644 (file)
index 0000000..c05c7e3
--- /dev/null
@@ -0,0 +1,36 @@
+From d128d10c5f1554254ce55f3c79ca08390279d628 Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Sun, 8 Mar 2020 13:04:55 +0800
+Subject: [PATCH] Support newer proc_ops interface for 5.6
+
+Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
+---
+ acpi_call.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/acpi_call.c b/acpi_call.c
+index 801798b..65eb344 100644
+--- a/acpi_call.c
++++ b/acpi_call.c
+@@ -348,11 +348,18 @@ static ssize_t acpi_proc_read( struct file *filp, char __user *buff,
+     return ret;
+ }
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 6, 0)
+ static struct file_operations proc_acpi_operations = {
+         .owner    = THIS_MODULE,
+         .read     = acpi_proc_read,
+         .write    = acpi_proc_write,
+ };
++#else
++static const struct proc_ops proc_acpi_operations = {
++        .proc_read  = acpi_proc_read,
++        .proc_write = acpi_proc_write,
++};
++#endif
+ #else
+ static int acpi_proc_read(char *page, char **start, off_t off,
+-- 
+2.25.1
+