net-mail/dovecot: security bump to 2.3.9.2
authorEray Aslan <eras@gentoo.org>
Sun, 15 Dec 2019 07:32:30 +0000 (10:32 +0300)
committerEray Aslan <eras@gentoo.org>
Sun, 15 Dec 2019 07:32:30 +0000 (10:32 +0300)
Bug: https://bugs.gentoo.org/702628
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Eray Aslan <eras@gentoo.org>
net-mail/dovecot/Manifest
net-mail/dovecot/dovecot-2.3.9.2.ebuild [new file with mode: 0644]

index 6e6335f9c0f8ebd0c238eff32fc0f0b76cbf93b0..861f7b11e2215356e9a4a51e3cf98b6e403be677 100644 (file)
@@ -5,4 +5,5 @@ DIST dovecot-2.3-pigeonhole-0.5.8.tar.gz 1857780 BLAKE2B a1b86c7757238c4bfb6ec4a
 DIST dovecot-2.3-pigeonhole-0.5.9.tar.gz 1897060 BLAKE2B 73b9abd0a7ea9468f7880fdd0d0471c5825f341c7297807c404ce50a8792f821d2599840ce9eb2705a118a0ee078aafad9f4f6eb64a02fbcb3b0f89c00042ada SHA512 1b8d2ac8d3985dde035fc45df519788a924ba971f3e39717f5196ea56a982d4156226586d0a964473525d086967883ea52f2e624e81f7035cb0952b76f2414d8
 DIST dovecot-2.3.7.2.tar.gz 7076231 BLAKE2B 2cb93aa594db722489063b490469dfe284b1f997b64c9a699b506ccbd04e8e7c2d503ddc12a2598958dfca88560c19487801a728f386b8fea5f637a75b83812e SHA512 172f7f0edb884259e4c050607510aee67a35c3a20b7dd147e7c8a25a04921c18f7d6b5c85af2c69ae8c4d53791550970e471b033dbfae94253e331053b6a317d
 DIST dovecot-2.3.8.tar.gz 7136958 BLAKE2B 2769169519f0fd9293178e8d200467bc5be0f362bc6bfb3dcc6cc74ed146ecf66dab7730013704b70f0cc75a87ee5e52994137cd63c7c12c56bddcea37cedd07 SHA512 f62439e2ea77ffb544a7752c07085582c5653c64671cb42dd7a7e5aa69eb87059c677aa1fa071efa1ddd2287ab621e9a264ec115be2aeb2f43ab4c685411eae3
+DIST dovecot-2.3.9.2.tar.gz 7182306 BLAKE2B 942718ebdb7c447096895fc4309dea930ff87166f06be3365c6463e2aed95bb2620a5e45a8ce260df647593d9d2cef1d2a3ba3aa0afb397dac81653f9a4fd519 SHA512 36e8270bfa33e2bd6aa89017e65c7d1650c494c79ff297759a4b01c026aebcfdf5b1b542d4357e1f9dc2bb8169ef67064f0699b17ca36d658deb70b4c800b253
 DIST dovecot-2.3.9.tar.gz 7181327 BLAKE2B 1fc3fc8e123fb5f495bcb635b14318c3ad2efbb196055955e6cafcb4fbf80899096424cb9c989badeee9bb49b770fd48ef07fbc59dab3f91a9caa17bbdd7ebe2 SHA512 6f7cfebb0d89709d971a6cd623375805dc018c6d8c4cdaa5f274a5a5b0830c2b135c9cf6c90d0983c70ca76e3def855c501ea32aeb7a67b104cb6676bb9d37db
diff --git a/net-mail/dovecot/dovecot-2.3.9.2.ebuild b/net-mail/dovecot/dovecot-2.3.9.2.ebuild
new file mode 100644 (file)
index 0000000..6a614a6
--- /dev/null
@@ -0,0 +1,286 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# do not add a ssl USE flag.  ssl is mandatory
+SSL_DEPS_SKIP=1
+inherit autotools ssl-cert systemd
+
+MY_P="${P/_/.}"
+#MY_S="${PN}-ce-${PV}"
+major_minor="$(ver_cut 1-2)"
+sieve_version="0.5.9"
+if [[ ${PV} == *_rc* ]] ; then
+       rc_dir="rc/"
+else
+       rc_dir=""
+fi
+SRC_URI="https://dovecot.org/releases/${major_minor}/${rc_dir}${MY_P}.tar.gz
+       sieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       )
+       managesieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       ) "
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="https://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE_DOVECOT_AUTH="kerberos ldap lua mysql pam postgres sqlite vpopmail"
+IUSE_DOVECOT_COMPRESS="bzip2 lzma lz4 zlib"
+IUSE_DOVECOT_OTHER="argon2 caps doc ipv6 libressl lucene managesieve selinux sieve solr static-libs suid tcpd textcat"
+
+IUSE="${IUSE_DOVECOT_AUTH} ${IUSE_DOVECOT_STORAGE} ${IUSE_DOVECOT_COMPRESS} ${IUSE_DOVECOT_OTHER}"
+
+DEPEND="argon2? ( dev-libs/libsodium )
+       bzip2? ( app-arch/bzip2 )
+       caps? ( sys-libs/libcap )
+       kerberos? ( virtual/krb5 )
+       ldap? ( net-nds/openldap )
+       lua? ( dev-lang/lua:* )
+       lucene? ( >=dev-cpp/clucene-2.3 )
+       lzma? ( app-arch/xz-utils )
+       lz4? ( app-arch/lz4 )
+       mysql? ( dev-db/mysql-connector-c:0= )
+       pam? ( sys-libs/pam )
+       postgres? ( dev-db/postgresql:* !dev-db/postgresql[ldap,threads] )
+       selinux? ( sec-policy/selinux-dovecot )
+       solr? ( net-misc/curl dev-libs/expat )
+       sqlite? ( dev-db/sqlite:* )
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       suid? ( acct-group/mail )
+       tcpd? ( sys-apps/tcp-wrappers )
+       textcat? ( app-text/libexttextcat )
+       vpopmail? ( net-mail/vpopmail )
+       zlib? ( sys-libs/zlib )
+       virtual/libiconv
+       dev-libs/icu:="
+
+RDEPEND="${DEPEND}
+       acct-group/dovecot
+       acct-group/dovenull
+       acct-user/dovecot
+       acct-user/dovenull
+       net-mail/mailbase"
+
+pkg_setup() {
+       if use managesieve && ! use sieve; then
+               ewarn "managesieve USE flag selected but sieve USE flag unselected"
+               ewarn "sieve USE flag will be turned on"
+       fi
+}
+
+src_prepare() {
+       default
+       # bug 657108
+       elibtoolize
+       #eautoreconf
+}
+
+src_configure() {
+       local conf=""
+
+       if use postgres || use mysql || use sqlite; then
+               conf="${conf} --with-sql"
+       fi
+
+       # turn valgrind tests off. Bug #340791
+       VALGRIND=no econf \
+               --with-rundir="${EPREFIX%/}/run/dovecot" \
+               --with-statedir="${EPREFIX%/}/var/lib/dovecot" \
+               --with-moduledir="${EPREFIX%/}/usr/$(get_libdir)/dovecot" \
+               --without-stemmer \
+               --disable-rpath \
+               --without-libbsd \
+               --with-icu \
+               --with-ssl \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+               $( use_with argon2 sodium ) \
+               $( use_with bzip2 bzlib ) \
+               $( use_with caps libcap ) \
+               $( use_with kerberos gssapi ) \
+               $( use_with lua ) \
+               $( use_with ldap ) \
+               $( use_with lucene ) \
+               $( use_with lz4 ) \
+               $( use_with lzma ) \
+               $( use_with mysql ) \
+               $( use_with pam ) \
+               $( use_with postgres pgsql ) \
+               $( use_with sqlite ) \
+               $( use_with solr ) \
+               $( use_with tcpd libwrap ) \
+               $( use_with textcat ) \
+               $( use_with vpopmail ) \
+               $( use_with zlib ) \
+               $( use_enable static-libs static ) \
+               ${conf}
+
+       if use sieve || use managesieve ; then
+               # The sieve plugin needs this file to be build to determine the plugin
+               # directory and the list of libraries to link to.
+               emake dovecot-config
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               econf \
+                       $( use_enable static-libs static ) \
+                       --localstatedir="${EPREFIX%/}/var" \
+                       --enable-shared \
+                       --with-dovecot="${S}" \
+                       $( use_with managesieve )
+       fi
+}
+
+src_compile() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+       fi
+}
+
+src_test() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               default
+       fi
+}
+
+src_install () {
+       default
+
+       # insecure:
+       # use suid && fperms u+s /usr/libexec/dovecot/deliver
+       # better:
+       if use suid;then
+               einfo "Changing perms to allow deliver to be suided"
+               fowners root:mail "/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "/usr/libexec/dovecot/dovecot-lda"
+       fi
+
+       newinitd "${FILESDIR}"/dovecot.init-r6 dovecot
+
+       rm -rf "${ED}"/usr/share/doc/dovecot
+
+       dodoc AUTHORS NEWS README TODO
+       dodoc doc/*.{txt,cnf,xml,sh}
+       docinto example-config
+       dodoc doc/example-config/*.{conf,ext}
+       docinto example-config/conf.d
+       dodoc doc/example-config/conf.d/*.{conf,ext}
+       docinto wiki
+       dodoc doc/wiki/*
+       doman doc/man/*.{1,7}
+
+       # Create the dovecot.conf file from the dovecot-example.conf file that
+       # the dovecot folks nicely left for us....
+       local conf="${ED}/etc/dovecot/dovecot.conf"
+       local confd="${ED}/etc/dovecot/conf.d"
+
+       insinto /etc/dovecot
+       doins doc/example-config/*.{conf,ext}
+       insinto /etc/dovecot/conf.d
+       doins doc/example-config/conf.d/*.{conf,ext}
+       fperms 0600 /etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       rm -f "${confd}/../README"
+
+       # .maildir is the Gentoo default
+       local mail_location="maildir:~/.maildir"
+       sed -i -e \
+               "s|#mail_location =|mail_location = ${mail_location}|" \
+               "${confd}/10-mail.conf" \
+               || die "failed to update mail location settings in 10-mail.conf"
+
+       # We're using pam files (imap and pop3) provided by mailbase
+       if use pam; then
+               sed -i -e '/driver = pam/,/^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+                       "${confd}/auth-system.conf.ext" \
+                       || die "failed to update PAM settings in auth-system.conf.ext"
+               # mailbase does not provide a sieve pam file
+               use managesieve && dosym imap /etc/pam.d/sieve
+               sed -i -e \
+                       's/#!include auth-system.conf.ext/!include auth-system.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update PAM settings in 10-auth.conf"
+       fi
+
+       # Disable ipv6 if necessary
+       if ! use ipv6; then
+               sed -i -e 's/^#listen = \*, ::/listen = \*/g' "${conf}" \
+                       || die "failed to update listen settings in dovecot.conf"
+       fi
+
+       # Update ssl cert locations
+       sed -i -e 's:^#ssl = yes:ssl = yes:' "${confd}/10-ssl.conf" \
+               || die "ssl conf failed"
+       sed -i -e 's:^ssl_cert =.*:ssl_cert = </etc/ssl/dovecot/server.pem:' \
+               -e 's:^ssl_key =.*:ssl_key = </etc/ssl/dovecot/server.key:' \
+               "${confd}/10-ssl.conf" || die "failed to update SSL settings in 10-ssl.conf"
+
+       # Install SQL configuration
+       if use mysql || use postgres; then
+               sed -i -e \
+                       's/#!include auth-sql.conf.ext/!include auth-sql.conf.ext/' \
+                       "${confd}/10-auth.conf" || die "failed to update SQL settings in \
+                       10-auth.conf"
+       fi
+
+       # Install LDAP configuration
+       if use ldap; then
+               sed -i -e \
+                       's/#!include auth-ldap.conf.ext/!include auth-ldap.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update ldap settings in 10-auth.conf"
+       fi
+
+       if use vpopmail; then
+               sed -i -e \
+                       's/#!include auth-vpopmail.conf.ext/!include auth-vpopmail.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update vpopmail settings in 10-auth.conf"
+       fi
+
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake DESTDIR="${ED}" install
+               sed -i -e \
+                       's/^[[:space:]]*#mail_plugins = $mail_plugins/mail_plugins = sieve/' "${confd}/15-lda.conf" \
+                       || die "failed to update sieve settings in 15-lda.conf"
+               rm -rf "${ED}"/usr/share/doc/dovecot
+               docinto example-config/conf.d
+               dodoc doc/example-config/conf.d/*.conf
+               insinto /etc/dovecot/conf.d
+               doins doc/example-config/conf.d/90-sieve{,-extprograms}.conf
+               use managesieve && doins doc/example-config/conf.d/20-managesieve.conf
+               docinto sieve/rfc
+               dodoc doc/rfc/*.txt
+               docinto sieve/devel
+               dodoc doc/devel/DESIGN
+               docinto plugins
+               dodoc doc/plugins/*.txt
+               docinto extensions
+               dodoc doc/extensions/*.txt
+               docinto locations
+               dodoc doc/locations/*.txt
+               doman doc/man/*.{1,7}
+       fi
+
+       use static-libs || find "${ED}"/usr/lib* -name '*.la' -delete
+}
+
+pkg_postinst() {
+       # Let's not make a new certificate if we already have one
+       if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+               -e "${ROOT}"/etc/ssl/dovecot/server.key ]];     then
+               einfo "Creating SSL     certificate"
+               SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+               install_cert /etc/ssl/dovecot/server
+       fi
+
+       elog "Please read https://wiki2.dovecot.org/Upgrading/ for upgrade notes."
+}