dev-python/node-semver: Add python3_6
authorManuel Rüger <mrueg@gentoo.org>
Wed, 17 May 2017 17:12:31 +0000 (19:12 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Wed, 17 May 2017 17:12:31 +0000 (19:12 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-python/node-semver/node-semver-0.1.1.ebuild

index eb9447fc5e208a5bc77ee613293f2435f27ee5cb..6285b77acb50a58e1916cafcb5605a07dd4430ae 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -17,4 +17,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+       # https://github.com/podhmo/python-semver/issues/4
+       sed -i -e "/github.com/d" semver/tests/test_negative_range.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       py.test || die
+}