dev-ruby/mixlib-shellout: add 2.4.0
authorHans de Graaff <graaff@gentoo.org>
Tue, 24 Jul 2018 05:34:53 +0000 (07:34 +0200)
committerHans de Graaff <graaff@gentoo.org>
Tue, 24 Jul 2018 05:34:53 +0000 (07:34 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-ruby/mixlib-shellout/Manifest
dev-ruby/mixlib-shellout/mixlib-shellout-2.4.0.ebuild [new file with mode: 0644]

index 960afec8cef2ba9d4dab1dd5bb13e051ffbbfadd..bd7ed4337ebd7f52502a81f8b10a4811b5bcb320 100644 (file)
@@ -1 +1,2 @@
 DIST mixlib-shellout-2.3.2.tar.gz 35828 BLAKE2B 8fa665a0be90da481d2e83aeb0bbfe35be6086cad25cfff5f079f0aa53926318961d2192da3477e4a4cd728e57752f32652579d544f562d81941a3d357c5bb5a SHA512 72f4979d1c444b1f097ecfd4767a2989e60398e84a78106b80077b664bc01d6fc68022cec26172f1e7c0384dd3fc4f64c723ad3a2882db7284dbadacc7cf24c9
+DIST mixlib-shellout-2.4.0.tar.gz 36249 BLAKE2B cf2da1936a95ace0d2f847c05e299834ea0fcb00ec47e6caeeb5b8e0e96d76b69ba9a43ce9846079ca707e4877c0a2bcde35a67a4d4f27e79192d2b88a97a653 SHA512 fccd70854449303aa107eeba0d7d58b5a0ff5db8aaeb52e49121340aefdeb25fe205f3a8cc80299e24c72ec99f89988c559ca72086610d39c6847b2208e95d57
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.4.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.4.0.ebuild
new file mode 100644 (file)
index 0000000..6c6bcd0
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+       # Make sure we actually use the right interpreter for testing
+       sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}