net-dialup/sendpage: use #!/sbin/openrc-run instead of #!/sbin/runscript
authorAustin English <wizardedit@gentoo.org>
Thu, 28 Apr 2016 21:55:52 +0000 (16:55 -0500)
committerAustin English <wizardedit@gentoo.org>
Thu, 28 Apr 2016 21:59:32 +0000 (16:59 -0500)
Gentoo-Bug: https://bugs.gentoo.org/573846

Package-Manager: portage-2.2.26

net-dialup/sendpage/files/sendpage.initd
net-dialup/sendpage/sendpage-1.1.0-r3.ebuild [new file with mode: 0644]

index 2fcf217a3df8aaf495a5660088be7cf6082a8276..3a46a8c26f389bbdf32531ad6593950a5c16e5bd 100644 (file)
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
diff --git a/net-dialup/sendpage/sendpage-1.1.0-r3.ebuild b/net-dialup/sendpage/sendpage-1.1.0-r3.ebuild
new file mode 100644 (file)
index 0000000..f985432
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit perl-module eutils user
+
+MY_P=${PN}-1.001
+DESCRIPTION="Dialup alphapaging software"
+HOMEPAGE="http://www.sendpage.org/"
+SRC_URI="http://www.sendpage.org/download/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# This package warrants IUSE doc
+IUSE=""
+
+DEPEND="!net-misc/hylafax
+       >=dev-perl/Device-SerialPort-0.13
+       >=dev-perl/MailTools-1.44
+       >=virtual/perl-libnet-1.11
+       >=dev-perl/Net-SNPP-1.13
+       dev-perl/DBI"
+RDEPEND="${DEPEND}"
+
+mydoc="FEATURES email2page.conf sendpage.cf snpp.conf"
+
+pkg_setup() {
+       enewgroup sms
+       enewuser sendpage -1 -1 /var/spool/sendpage sms
+}
+
+PATCHES=( "${FILESDIR}"/${PV}-makefile.patch )
+
+src_install() {
+       perl-module_src_install
+       insinto /etc
+       doins sendpage.cf
+       newinitd "${FILESDIR}"/sendpage.initd sendpage
+       diropts -o sendpage -g sms -m0770
+       keepdir /var/spool/sendpage
+       # Separate docs/ content from ${mydoc[@]}
+       docompress -x /usr/share/doc/${PF}/text/
+       docinto text/
+       dodoc docs/*
+}