sys-libs/ncurses: Revbump to not bleed LDFLAGS into Libs
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 13 Feb 2020 11:38:14 +0000 (12:38 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 13 Feb 2020 11:44:23 +0000 (12:44 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/ncurses/files/ncurses-6.2-no_user_ldflags_in_libs.patch [new file with mode: 0644]
sys-libs/ncurses/ncurses-6.2-r1.ebuild [moved from sys-libs/ncurses/ncurses-6.2.ebuild with 99% similarity]

diff --git a/sys-libs/ncurses/files/ncurses-6.2-no_user_ldflags_in_libs.patch b/sys-libs/ncurses/files/ncurses-6.2-no_user_ldflags_in_libs.patch
new file mode 100644 (file)
index 0000000..66345b5
--- /dev/null
@@ -0,0 +1,40 @@
+From be554be06475b36da2f69aabfd873ad55f7ef95c Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Thu, 13 Feb 2020 11:51:09 +0100
+Subject: [PATCH] Don't bleed user LDFLAGS into Libs
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ misc/gen-pkgconfig.in  | 2 +-
+ misc/ncurses-config.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/misc/gen-pkgconfig.in b/misc/gen-pkgconfig.in
+index 8f00b824..009d2156 100644
+--- a/misc/gen-pkgconfig.in
++++ b/misc/gen-pkgconfig.in
+@@ -80,7 +80,7 @@ if [ "$includedir" != "/usr/include" ]; then
+ fi
+ lib_flags=
+-for opt in -L$libdir @LDFLAGS@ @EXTRA_LDFLAGS@ @LIBS@
++for opt in -L$libdir @LIBS@
+ do
+       case $opt in
+       -l*) # LIBS is handled specially below
+diff --git a/misc/ncurses-config.in b/misc/ncurses-config.in
+index 7f8ba697..2f1915cd 100644
+--- a/misc/ncurses-config.in
++++ b/misc/ncurses-config.in
+@@ -101,7 +101,7 @@ fi
+ # There is no portable way to find the list of standard library directories. 
+ # Require a POSIX shell anyway, to keep this simple.
+ lib_flags=
+-for opt in -L$libdir @LDFLAGS@ @EXTRA_LDFLAGS@ $LIBS
++for opt in -L$libdir $LIBS
+ do
+       case $opt in
+       -specs*) # ignore linker specs-files which were used to build library
+-- 
+2.25.0
+
similarity index 99%
rename from sys-libs/ncurses/ncurses-6.2.ebuild
rename to sys-libs/ncurses/ncurses-6.2-r1.ebuild
index b5bc19b8f78d285844b0bd6c7df6d101a28baf1d..6c96fc33f99aaf9ab3424eea6cc612c0c8d3f8af 100644 (file)
@@ -41,6 +41,7 @@ PATCHES=(
        "${FILESDIR}/${PN}-5.9-gcc-5.patch" #545114
        "${FILESDIR}/${PN}-6.0-ticlib.patch" #557360
        "${FILESDIR}/${PN}-6.0-cppflags-cross.patch" #601426
+       "${FILESDIR}/${PN}-6.2-no_user_ldflags_in_libs.patch"
 )
 
 src_prepare() {