x11-wm/marco: Add explicit subslots
authorAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 19:16:57 +0000 (15:16 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 20:18:41 +0000 (16:18 -0400)
Bug: https://bugs.gentoo.org/694136
Package-Manager: Portage-2.3.96, Repoman-2.3.21
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
x11-wm/marco/Manifest
x11-wm/marco/marco-1.22.1-r2.ebuild [moved from x11-wm/marco/marco-1.22.1-r1.ebuild with 99% similarity]
x11-wm/marco/marco-1.22.4-r1.ebuild [moved from x11-wm/marco/marco-1.22.2.ebuild with 99% similarity]
x11-wm/marco/marco-1.24.0-r1.ebuild [new file with mode: 0644]

index 06a9ac8f9937d3cb1850e01777e1ab54547d2b12..95f3f8a0ecf099d0fb854903ed2deb9ec658ffc0 100644 (file)
@@ -1,4 +1,3 @@
 DIST marco-1.22.1.tar.xz 1357864 BLAKE2B 241e71795acfdcbf90070ef0d14f0cc55894a5cddbf48bd8741cf9580cfcaa035890b23a2182738875ce4d89d099a80d59aa7b1937e4a34a18a5a969830e7db9 SHA512 18093f4d419fbc90f957a04ec3e36a153b3c51a6bcdc1ac5884adcc0292f157bc5e4af51e171451a4b54b5bccffdee2e8a07ed13dafb6106773abfb06b6a8a4f
-DIST marco-1.22.2.tar.xz 1366104 BLAKE2B 6caa7da12c32b8adcc6d3ab4525fcf9e892585cb528bd73e47af1e2eeda2c31d174e55acd98f9a4759e22176fa06aa13d8a6ef6a6b2cc82d11bed27b156d6739 SHA512 96665120dbc698c78795eeaa559ae2bfd2a3c7ed4846e40bcfb1d6dfc8d7e359b860e1e715085a17e11c66ce7f31561d372da8372209c21c7b1ce6029a3f5ea1
 DIST marco-1.22.4.tar.xz 1368868 BLAKE2B 45a1bdfa13419f690e4a1604a18f1ef4f57b95cc64c628a8d1c4b8d5a92409eb8ecb946b60c9b9711151858a4668247f2ee031a95464463f3005952edd95265c SHA512 46867396b66453c63624e54c382845b898b10768db0560100f021e57ec80189785093be38eeaf19c50a9e4728de2b6e605267a8f1d5a5596aaa75958c0e3a6b0
 DIST marco-1.24.0.tar.xz 1827076 BLAKE2B e4bcf8584199cbe4f9f813c7512176dd9b84a39ed162cd051f1f174c428828d1d73d6ab64c19ca681f0aea966742e0474256935f2a7c0c490b77dda91147162c SHA512 b257994c097f174fe83f3f0f4d6b6991e8c0f402daffd99f8a9521d588b609c56953e73dd4d143be64f5c9a4caa8d890ff30a120e18a9d5b36c6f856a7190428
similarity index 99%
rename from x11-wm/marco/marco-1.22.1-r1.ebuild
rename to x11-wm/marco/marco-1.22.1-r2.ebuild
index 2bc660edd39045d332ccb2d4bcaf0331a4987f01..a55e5ffb66ba4423750d72d7492c314edd878eec 100644 (file)
@@ -13,7 +13,7 @@ fi
 
 DESCRIPTION="MATE default window manager"
 LICENSE="FDL-1.2+ GPL-2+ LGPL-2+ MIT"
-SLOT="0"
+SLOT="0/1"
 
 IUSE="startup-notification test xinerama"
 RESTRICT="!test? ( test )"
similarity index 99%
rename from x11-wm/marco/marco-1.22.2.ebuild
rename to x11-wm/marco/marco-1.22.4-r1.ebuild
index a693ad0e7c524a90d26737b27f31574150ca82a4..f20058b183b5587b78fcf7a602610d7f5fef4397 100644 (file)
@@ -13,7 +13,7 @@ fi
 
 DESCRIPTION="MATE default window manager"
 LICENSE="FDL-1.2+ GPL-2+ LGPL-2+ MIT"
-SLOT="0"
+SLOT="0/2"
 
 IUSE="startup-notification test xinerama"
 RESTRICT="!test? ( test )"
diff --git a/x11-wm/marco/marco-1.24.0-r1.ebuild b/x11-wm/marco/marco-1.24.0-r1.ebuild
new file mode 100644 (file)
index 0000000..83c4dce
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE default window manager"
+LICENSE="FDL-1.2+ GPL-2+ LGPL-2+ MIT"
+SLOT="0/2"
+
+IUSE="startup-notification test xinerama"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+       dev-libs/atk
+       >=dev-libs/glib-2.58:2
+       >=gnome-base/libgtop-2:2=
+       media-libs/libcanberra[gtk3]
+       x11-libs/cairo
+       >=x11-libs/pango-1.2[X]
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/gtk+-3.22:3
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libX11
+       >=x11-libs/libXcomposite-0.3
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXpresent
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       >=x11-libs/startup-notification-0.7
+       xinerama? ( x11-libs/libXinerama )
+       !!x11-wm/mate-window-manager"
+
+RDEPEND="${COMMON_DEPEND}
+       gnome-extra/zenity
+       >=mate-base/mate-desktop-1.20.0
+       virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+       app-text/yelp-tools
+       >=sys-devel/gettext-0.19.8:*
+       >=sys-devel/libtool-2.0.0
+       virtual/pkgconfig:*
+       x11-base/xorg-proto
+       test? ( app-text/docbook-xml-dtd:4.5 )
+       xinerama? ( x11-base/xorg-proto )"
+
+src_configure() {
+       mate_src_configure \
+               --enable-compositor \
+               --enable-render \
+               --enable-shape \
+               --enable-sm \
+               --enable-xsync \
+               $(use_enable startup-notification) \
+               $(use_enable xinerama)
+}
+
+src_install() {
+       mate_src_install
+       dodoc doc/*.txt
+}