dev-java/jvmstat: clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 31 Mar 2019 18:53:18 +0000 (20:53 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 1 Apr 2019 08:51:35 +0000 (10:51 +0200)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-java/jvmstat/jvmstat-3.0.ebuild [deleted file]

diff --git a/dev-java/jvmstat/jvmstat-3.0.ebuild b/dev-java/jvmstat/jvmstat-3.0.ebuild
deleted file mode 100644 (file)
index 2d11cc6..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit java-pkg-2 versionator
-
-MY_PV=$(replace_version_separator 1 '_')
-DESCRIPTION="Monitoring APIs and tools for monitoring the performance of the JVM"
-HOMEPAGE="http://java.sun.com/performance/jvmstat/"
-SRC_URI="jvmstat-${MY_PV}.zip"
-
-LICENSE="sun-bcla-jvmstat"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RESTRICT="fetch strip"
-
-DEPEND="app-arch/unzip"
-RDEPEND=">=virtual/jre-1.5"
-
-S="${WORKDIR}/jvmstat/"
-
-INSTTO="/opt/${PN}"
-
-pkg_nofetch() {
-
-       einfo "Please go to following URL:"
-       einfo " ${HOMEPAGE}"
-       einfo "download file named ${SRC_URI} and place it into"
-       einfo " your DISTDIR directory."
-
-}
-
-src_install() {
-
-       dodir "${INSTTO}"
-       cd "${S}"
-       cp -r jars bin "${D}/${INSTTO}"
-
-       dodoc README
-       use doc && dodoc -r docs
-
-       dodir /opt/bin
-       cat > "${D}/opt/bin/visualgc" <<-EOF
-       #!/bin/bash
-       export JVMSTAT_JAVA_HOME=$(java-config -O)
-       cd /opt/jvmstat/bin/
-       ./visualgc \${@}
-       EOF
-       fperms 755 /opt/bin/visualgc
-
-}