dev-python/hypothesis: Bump to 4.54.0
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 07:27:08 +0000 (08:27 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 08:09:35 +0000 (09:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-4.54.0.ebuild [new file with mode: 0644]

index bbb39e35b9853a2d374f06b7d861f3bbd3b07e2a..d25ca8c3c5b3c52a0a245b492542d5978d659647 100644 (file)
@@ -2,3 +2,4 @@ DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad258
 DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
 DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
 DIST hypothesis-python-4.53.2.tar.gz 6815827 BLAKE2B 219ef79b8575f835e5df835a25354041007d44fd517c0f38b1686f5a74660b8f489eb6ceb9ae9a48f67792ec62058647ce76e62c156400fa0de808b03ad41630 SHA512 d2ff624c10e13ff040bdf05b9082f37b2e7529bb9cc98f3972f8240d3802a034580720983e98b7ba6165a98e64ac5692b1e14f5c490f8aabdb9ea7c19364b66f
+DIST hypothesis-python-4.54.0.tar.gz 6816820 BLAKE2B 1d92c9c5d7370607560a77f481222448b371d437ada3305c5043bc4b7cfadd890c1dcd88692b2bbfd422975073161ad0dc34ff467f1facb8be9a6afb6cb291b7 SHA512 f4ce74e7180de6463197a6c3e9266c8be39545ea955a83291db2ceace5f146ff39c2502e16b5569f4196704ad21891f77c25db94e9d7aedb8ce2e694067e5ba1
diff --git a/dev-python/hypothesis/hypothesis-4.54.0.ebuild b/dev-python/hypothesis/hypothesis-4.54.0.ebuild
new file mode 100644 (file)
index 0000000..3def9e8
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pexpect[${PYTHON_USEDEP}]
+               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+               !!<dev-python/typing-3.7.4.1
+       )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+       # avoid pytest-xdist dep for one test
+       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+               tests/pytest/test_statistics.py || die
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       local pyver=$(python_is_python3 && echo 3 || echo 2)
+       pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+               die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       optfeature "datetime support" dev-python/pytz
+       optfeature "dateutil support" dev-python/python-dateutil
+       optfeature "numpy support" dev-python/numpy
+       optfeature "django support" dev-python/django dev-python/pytz
+       optfeature "pandas support" dev-python/pandas
+       optfeature "pytest support" dev-python/pytest
+}