sys-fs/lde: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 26 Feb 2017 22:48:16 +0000 (23:48 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 26 Feb 2017 22:49:29 +0000 (23:49 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sys-fs/lde/lde-2.6.1-r1.ebuild [new file with mode: 0644]

diff --git a/sys-fs/lde/lde-2.6.1-r1.ebuild b/sys-fs/lde/lde-2.6.1-r1.ebuild
new file mode 100644 (file)
index 0000000..18a1283
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="ext2fs and minix disk editor for linux"
+HOMEPAGE="http://lde.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="
+       ${RDEPEND}
+       dev-util/yacc"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+       "${FILESDIR}/${P}-no-shadowing.patch"
+)
+
+DOCS=( WARNING README TODO COPYING )
+
+RESTRICT="test"
+
+src_install() {
+       dosbin "${PN}"
+       newman "doc/${PN}.man" "${PN}.8"
+       einstalldocs
+}