dev-python/jira: allow dev-python/pycryptodome as well as dev-python/pycrypto, Bug...
authorAustin English <wizardedit@gentoo.org>
Wed, 13 Dec 2017 23:00:50 +0000 (17:00 -0600)
committerAustin English <wizardedit@gentoo.org>
Wed, 13 Dec 2017 23:01:35 +0000 (17:01 -0600)
Gentoo-Bug: https://bugs.gentoo.org/611568
Gentoo-Bug: https://bugs.gentoo.org/611596
Package-Manager: Portage-2.3.13, Repoman-2.3.3

dev-python/jira/jira-1.0.10-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/jira/jira-1.0.10-r1.ebuild b/dev-python/jira/jira-1.0.10-r1.ebuild
new file mode 100644 (file)
index 0000000..023e136
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for interacting with the JIRA REST API"
+HOMEPAGE="https://jira.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="filemagic ipython oauth"
+
+DEPEND="
+       dev-python/pbr[${PYTHON_USEDEP}]
+       dev-python/pytest-runner[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       "
+RDEPEND="
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       filemagic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
+       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+       oauth? (
+               || ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )
+               dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+       )
+       "