dev-ros/roscpp_serialization: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 09:13:07 +0000 (11:13 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 09:13:20 +0000 (11:13 +0200)
Package-Manager: portage-2.2.21

dev-ros/roscpp_serialization/Manifest [new file with mode: 0644]
dev-ros/roscpp_serialization/metadata.xml [new file with mode: 0644]
dev-ros/roscpp_serialization/roscpp_serialization-0.5.6.ebuild [new file with mode: 0644]
dev-ros/roscpp_serialization/roscpp_serialization-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/roscpp_serialization/Manifest b/dev-ros/roscpp_serialization/Manifest
new file mode 100644 (file)
index 0000000..3fcf6e4
--- /dev/null
@@ -0,0 +1 @@
+DIST roscpp_core-0.5.6.tar.gz 31734 SHA256 0bd27394c18c7c79313ebc4eafecc04f88aa54a9d0872357b7123105444edf3a SHA512 caebca2817721a46c8ce850bc15bdeadb3bf6ad12aeb134b11bdb04da6054eb4056aef8c5194ca4e7fffa3e3f3563faf8e3148eebfba93bc6b5673d5437d977f WHIRLPOOL f977f9b0e10a287c7d201ffd765a4824e61d0b5f85767c7a8e81d96295f97dcbe22a9c2d376f36a329997d0498ce36f830263e4710eaf288b214b6bf894ede84
diff --git a/dev-ros/roscpp_serialization/metadata.xml b/dev-ros/roscpp_serialization/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/roscpp_serialization/roscpp_serialization-0.5.6.ebuild b/dev-ros/roscpp_serialization/roscpp_serialization-0.5.6.ebuild
new file mode 100644 (file)
index 0000000..5ce015d
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Code for serialization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/cpp_common
+       dev-ros/rostime
+       dev-ros/roscpp_traits
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/roscpp_serialization/roscpp_serialization-9999.ebuild b/dev-ros/roscpp_serialization/roscpp_serialization-9999.ebuild
new file mode 100644 (file)
index 0000000..5ce015d
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Code for serialization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/cpp_common
+       dev-ros/rostime
+       dev-ros/roscpp_traits
+"
+DEPEND="${RDEPEND}"