dev-perl/USB-TMC: Bump to version 0.6.0
authorKent Fredric <kentnl@gentoo.org>
Mon, 19 Mar 2018 06:18:11 +0000 (19:18 +1300)
committerKent Fredric <kentnl@gentoo.org>
Mon, 19 Mar 2018 06:39:06 +0000 (19:39 +1300)
- Exorcise Pod Author tests
- Add missing CPAN remote-id's

Upstream:
- Add documentation about Udev rules and USB::LibUSB

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/USB-TMC/Manifest
dev-perl/USB-TMC/USB-TMC-0.6.0.ebuild [new file with mode: 0644]
dev-perl/USB-TMC/files/USB-TMC-0.006-nopodtest.patch [new file with mode: 0644]
dev-perl/USB-TMC/metadata.xml

index df7e6b13595bae2e49c542985a991db008ebaadc..1936dec0ed0afe2ddb1027cbebc10d6f96c4bcbc 100644 (file)
@@ -1 +1,2 @@
 DIST USB-TMC-0.005.tar.gz 14897 BLAKE2B e0ef62ce0263ab2c094562ad0ab23a2b7847c8e192d82cb3104a3e1cc0177de0d9cf384c337ff0ef1f81da68674063052b1fc217c00d542d6c0f557c176a253b SHA512 25646376dcabab92c4abf82e22649dcea3659762b17860b09280d314deeb373b32fae962d284d9d3eadcd5c2d07da1285f873dd3408c0c6425cafb3082c07575
+DIST USB-TMC-0.006.tar.gz 15154 BLAKE2B a67846e4ab1e558f07498324253370f26a7392bc4cb5f8df078c73fc59fe897d36720f64d8a02e08ce59a5f12ee99c259f144d8ce3e7fbfb060b300fd45017f5 SHA512 8ac2e380bbc2cf78853502485d8af16141688cf6059db580439f1c10a3fcfbaf6241cab226f3845708f801651bd3cf0d8bcd89a1aa75c46f68e2bbe2430abbbf
diff --git a/dev-perl/USB-TMC/USB-TMC-0.6.0.ebuild b/dev-perl/USB-TMC/USB-TMC-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..917206c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_VERSION=0.006
+DIST_AUTHOR=AMBA
+KEYWORDS="~amd64 ~x86"
+inherit perl-module
+
+DESCRIPTION="Perl interface to the USB Test & Measurement (USBTMC) backend"
+
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-Carp
+       virtual/perl-Data-Dumper
+       dev-perl/Moose
+       dev-perl/MooseX-Params-Validate
+       dev-perl/USB-LibUSB
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+PATCHES=("${FILESDIR}/${PN}-0.006-nopodtest.patch")
diff --git a/dev-perl/USB-TMC/files/USB-TMC-0.006-nopodtest.patch b/dev-perl/USB-TMC/files/USB-TMC-0.006-nopodtest.patch
new file mode 100644 (file)
index 0000000..f5b5279
--- /dev/null
@@ -0,0 +1,80 @@
+From 41dbe34a7cd28e3841ac71184753f9e22cdf425d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 19 Mar 2018 18:59:30 +1300
+Subject: Relocate t/pod.t to be an author only test
+
+This avoids end users needlessly running the POD tests if they just
+happen to have Test::Pod installed, and also avoids the resulting
+unneeded dependency on Module::Load
+
+Bug: https://github.com/lab-measurement/USB-TMC/pull/1
+---
+ MANIFEST               | 2 +-
+ META.json              | 1 -
+ META.yml               | 1 -
+ Makefile.PL            | 2 --
+ {t => xt/author}/pod.t | 0
+ 5 files changed, 1 insertion(+), 5 deletions(-)
+ rename {t => xt/author}/pod.t (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index ba36c09..850b6ca 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -12,4 +12,4 @@ lib/USB/TMC.pm
+ scripts/load.pl
+ scripts/test.pl
+ t/USB-TMC.t
+-t/pod.t
++xt/author/pod.t
+diff --git a/META.json b/META.json
+index 8c1f927..159b1e8 100644
+--- a/META.json
++++ b/META.json
+@@ -33,7 +33,6 @@
+       },
+       "test" : {
+          "requires" : {
+-            "Module::Load" : "0",
+             "Test::More" : "0"
+          }
+       }
+diff --git a/META.yml b/META.yml
+index a5ee3a1..ecc78b8 100644
+--- a/META.yml
++++ b/META.yml
+@@ -3,7 +3,6 @@ abstract: 'Perl interface to USB Test & Measurement (USBTMC) backend.'
+ author:
+   - 'Simon Reinhardt <simon.reinhardt@stud.uni-regensburg.de>'
+ build_requires:
+-  Module::Load: '0'
+   Test::More: '0'
+ configure_requires:
+   ExtUtils::MakeMaker: '0'
+diff --git a/Makefile.PL b/Makefile.PL
+index ae75f3e..b29c441 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -26,7 +26,6 @@ my %WriteMakefileArgs = (
+     "warnings" => 0
+   },
+   "TEST_REQUIRES" => {
+-    "Module::Load" => 0,
+     "Test::More" => 0
+   },
+   "VERSION" => "0.006",
+@@ -39,7 +38,6 @@ my %WriteMakefileArgs = (
+ my %FallbackPrereqs = (
+   "Carp" => 0,
+   "Data::Dumper" => 0,
+-  "Module::Load" => 0,
+   "Moose" => 0,
+   "MooseX::Params::Validate" => 0,
+   "Test::More" => 0,
+diff --git a/t/pod.t b/xt/author/pod.t
+similarity index 100%
+rename from t/pod.t
+rename to xt/author/pod.t
+-- 
+2.16.2
+
index e10a656f860c931df6bf7268d5ac0ea577248212..1038ebf526c61d78eaa4ef1326b03934fd45a2a5 100644 (file)
@@ -9,4 +9,8 @@
     <email>sci@gentoo.org</email>
     <name>Gentoo Science Project</name>
   </maintainer>
+  <upstream>
+    <remote-id type="cpan">USB-TMC</remote-id>
+    <remote-id type="cpan-module">USB::TMC</remote-id>
+  </upstream>
 </pkgmetadata>