net-libs/nodejs: Update python interpreter configuration
authorJeroen Roovers <jer@gentoo.org>
Wed, 20 Nov 2019 12:12:55 +0000 (13:12 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 20 Nov 2019 12:15:13 +0000 (13:15 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/nodejs/nodejs-13.0.1.ebuild
net-libs/nodejs/nodejs-13.1.0.ebuild
net-libs/nodejs/nodejs-99999999.ebuild

index 64dd1ca4d1516eb698d05cacb581f945d02e801d..56bbeb5526f4e3db83adf5cece7219114cc0d612 100644 (file)
@@ -60,9 +60,6 @@ src_prepare() {
        # https://code.google.com/p/gyp/issues/detail?id=260
        sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
 
-       # make sure we use python2.* while using gyp
-       sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
        # less verbose install output (stating the same as portage, basically)
        sed -i -e "/print/d" tools/install.py || die
 
@@ -119,7 +116,7 @@ src_configure() {
        GYP_DEFINES="linux_use_gold_flags=0
                linux_use_bundled_binutils=0
                linux_use_bundled_gold=0" \
-       "${PYTHON}" configure \
+       "${EPYTHON}" configure.py \
                --prefix="${EPREFIX}"/usr \
                --dest-cpu=${myarch} \
                $(use_with systemtap dtrace) \
@@ -192,7 +189,7 @@ src_install() {
 
 src_test() {
        out/${BUILDTYPE}/cctest || die
-       "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+       "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
 }
 
 pkg_postinst() {
index 64dd1ca4d1516eb698d05cacb581f945d02e801d..56bbeb5526f4e3db83adf5cece7219114cc0d612 100644 (file)
@@ -60,9 +60,6 @@ src_prepare() {
        # https://code.google.com/p/gyp/issues/detail?id=260
        sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
 
-       # make sure we use python2.* while using gyp
-       sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
        # less verbose install output (stating the same as portage, basically)
        sed -i -e "/print/d" tools/install.py || die
 
@@ -119,7 +116,7 @@ src_configure() {
        GYP_DEFINES="linux_use_gold_flags=0
                linux_use_bundled_binutils=0
                linux_use_bundled_gold=0" \
-       "${PYTHON}" configure \
+       "${EPYTHON}" configure.py \
                --prefix="${EPREFIX}"/usr \
                --dest-cpu=${myarch} \
                $(use_with systemtap dtrace) \
@@ -192,7 +189,7 @@ src_install() {
 
 src_test() {
        out/${BUILDTYPE}/cctest || die
-       "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+       "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
 }
 
 pkg_postinst() {
index e5e6f8a9d81c0898be40c98cf122ecef9f265656..e36828c990ad5011a9030b821d35f8399b4491ca 100644 (file)
@@ -56,9 +56,6 @@ src_prepare() {
        # https://code.google.com/p/gyp/issues/detail?id=260
        sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
 
-       # make sure we use python2.* while using gyp
-       sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
        # less verbose install output (stating the same as portage, basically)
        sed -i -e "/print/d" tools/install.py || die
 
@@ -115,7 +112,7 @@ src_configure() {
        GYP_DEFINES="linux_use_gold_flags=0
                linux_use_bundled_binutils=0
                linux_use_bundled_gold=0" \
-       "${PYTHON}" configure \
+       "${EPYTHON}" configure.py \
                --prefix="${EPREFIX}"/usr \
                --dest-cpu=${myarch} \
                $(use_with systemtap dtrace) \
@@ -188,7 +185,7 @@ src_install() {
 
 src_test() {
        out/${BUILDTYPE}/cctest || die
-       "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+       "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
 }
 
 pkg_postinst() {