dev-python/msgpack: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Mar 2020 17:09:23 +0000 (18:09 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 22 Mar 2020 05:36:54 +0000 (06:36 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/msgpack/Manifest
dev-python/msgpack/msgpack-0.4.8.ebuild [deleted file]
dev-python/msgpack/msgpack-0.5.1.ebuild [deleted file]
dev-python/msgpack/msgpack-0.6.1.ebuild [deleted file]

index d408b5bb72b23024e0efcfdf7caeac97ae0e5759..b7aedd2bb4228ad4938d9cf12d95ccebc00b59e3 100644 (file)
@@ -1,5 +1,2 @@
 DIST msgpack-0.5.6.tar.gz 138292 BLAKE2B 6a3b8472b785d77e142d21464b9e52c55166a8eff56009f63df5daa8cd5b6dbce4406a06ffa8d478cb44dfbdfab2f3b4b29cd11279ea82f67906b97d507f7eda SHA512 bdbd193bd3bd02e78d9c6e8d9d8fa687d13583dff2813bc77c5e6cbbe0d180765da3c9a80d176f9993589e35f548ad04973e3d523d0b6d41ef7916ecd86195aa
-DIST msgpack-0.6.1.tar.gz 118812 BLAKE2B 9f5522ae7dc89e286a338bfdd91bd4cacefdf7d075136a2ce5e28896db9a9c6a9ed1fe71fff45aab09f8dd32878fcd996366346daa88d47a31a253dec06e2353 SHA512 1a60da428f4b69df817660f4c4f60b1744de17d2b72352286fb41c6703de1d100853f8701b947fb11fc38f2180a50be4a9d577550fcfb9da6a05fe30ed2af07c
 DIST msgpack-0.6.2.tar.gz 119062 BLAKE2B 6b20a0d31b811ae66e66dbfaacec6f0cf2152b2937423b78f3e6244bfa49c87767788c5ee1db41b9020801b8777a4c15b1fe1853182718adf622bc7e1bff858e SHA512 95b92e3d35e0500dd4256d18bf76e586e57cc66319b4459ac5daef599277a5049177a89ad86e291dbdc4c7a918901a89d9218353ddc4a7d0b399e8a98afef363
-DIST msgpack-python-0.4.8.tar.gz 113641 BLAKE2B d22efe13302e28d0701b95b2dc4cf4792f9e045efdf77b31ac5c6170b503c885c265ff63387fe76a1aa67b1624963aa26d76dffb15fc2cb10cfe672b59e71b99 SHA512 59e9c43be6b92e6d10f40999e0902c350137e67a83c43bb15b273eca856a6eb39f24b625b02b40188a9365ce3101f03bfa9aa3dfff56c5c3b551533942183481
-DIST msgpack-python-0.5.1.tar.gz 138953 BLAKE2B 1fb7e5be33992808319e1444ff7f84cc13f034e60ce0ef2f72161bd4ccd0cd1ede27382bc1f365f268557c8ffe503fd12de66eb5840e79760d818e7e2f67fdcd SHA512 e5172e20bb25d2e12ba34ad2805ba4ea0776397986e8bf8e26d21353f57a2dba59a9c6669c817e4e91d5801558a50f95d81e02343f8f0292a01ec5d822fba61c
diff --git a/dev-python/msgpack/msgpack-0.4.8.ebuild b/dev-python/msgpack/msgpack-0.4.8.ebuild
deleted file mode 100644 (file)
index 3c1a966..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="${PN}-python"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="https://msgpack.org
-       https://github.com/msgpack/msgpack-python/
-       https://pypi.org/project/msgpack-python/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/six[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )
-"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
-       py.test test || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/msgpack/msgpack-0.5.1.ebuild b/dev-python/msgpack/msgpack-0.5.1.ebuild
deleted file mode 100644 (file)
index 134f67e..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="${PN}-python"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="https://msgpack.org
-       https://github.com/msgpack/msgpack-python/
-       https://pypi.org/project/msgpack-python/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/cython[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )
-"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
-       py.test test || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/msgpack/msgpack-0.6.1.ebuild b/dev-python/msgpack/msgpack-0.6.1.ebuild
deleted file mode 100644 (file)
index 4430835..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="https://msgpack.org
-       https://github.com/msgpack/msgpack-python/
-       https://pypi.org/project/msgpack/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc x86"
-IUSE="+native-extensions test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       native-extensions? (
-               $(python_gen_cond_dep '>=dev-python/cython-0.16[${PYTHON_USEDEP}]' 'python*')
-       )
-       test? (
-               dev-python/six[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       # Remove pre-generated cython files
-       rm msgpack/{_packer,_unpacker,_cmsgpack}.pyx || die
-
-       if ! use native-extensions ; then
-               sed -i -e "/have_cython/s:True:False:" ./setup.py || die
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test -v test || die "Tests fail with ${EPYTHON}"
-}