media-plugins/kodi-audiodecoder-timidity: depend on libplatform
authorCraig Andrews <candrews@gentoo.org>
Mon, 28 Jan 2019 01:54:32 +0000 (20:54 -0500)
committerCraig Andrews <candrews@gentoo.org>
Mon, 28 Jan 2019 01:55:14 +0000 (20:55 -0500)
Closes: https://bugs.gentoo.org/show_bug.cgi?id=676380
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-audiodecoder-timidity/kodi-audiodecoder-timidity-2.0.1-r1.ebuild [new file with mode: 0644]
media-plugins/kodi-audiodecoder-timidity/kodi-audiodecoder-timidity-9999.ebuild

diff --git a/media-plugins/kodi-audiodecoder-timidity/kodi-audiodecoder-timidity-2.0.1-r1.ebuild b/media-plugins/kodi-audiodecoder-timidity/kodi-audiodecoder-timidity-2.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..bb7b4c8
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Timidity decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.timidity"
+SRC_URI=""
+
+case ${PV} in
+9999)
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.timidity.git"
+       inherit git-r3
+       ;;
+*)
+       CODENAME="Leia"
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/notspiff/audiodecoder.timidity/archive/${PV}-${CODENAME}.tar.gz -> ${P}-${CODENAME}.tar.gz"
+       S="${WORKDIR}/audiodecoder.timidity-${PV}-${CODENAME}"
+       ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =media-tv/kodi-18*
+       =dev-libs/libplatform-2*
+       "
+RDEPEND="
+       ${DEPEND}
+       "
index 9bcec2d315b54dbf682dab5dd3c4a34bab899378..e99b24fbb32411a6b8de42e7a1994e83b8b7c83e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -29,6 +29,7 @@ IUSE=""
 
 DEPEND="
        ~media-tv/kodi-9999
+       =dev-libs/libplatform-2*
        "
 RDEPEND="
        ${DEPEND}