dev-libs/libsass: version bump 3.6.4
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Fri, 1 May 2020 15:50:14 +0000 (17:50 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 2 May 2020 11:54:59 +0000 (12:54 +0100)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
dev-libs/libsass/Manifest
dev-libs/libsass/libsass-3.6.4.ebuild [new file with mode: 0644]

index 031f55851910ea8912efe43c481f3d6485e5f61b..0ec444c8161318c438c0f6c4ee79f9a4decb772e 100644 (file)
@@ -1,2 +1,3 @@
 DIST libsass-3.6.1.tar.gz 333609 BLAKE2B ea6cb0285a6d741614bb900ff0f3b74660c74ec9ed071abf2d980bfe3f55b02fa2873d3860e5b767ca82b5f202f3d2aef28b73357bf8d2b3117c925b4dc78791 SHA512 e9a3a30851e26145d049c4b20951c663a9d48c781a732acd3cc2cdb30df3449e445b57211f666b58afa137431fbdb149add48ff8a0dec92bd8abb514c90adebb
 DIST libsass-3.6.3.tar.gz 331301 BLAKE2B 9e25994d19bd93fb53be32f69cafa40204d5892bd676fd7e9a3fcfe4cb6e84d21e9c53043b4766b602f811617f4eeb8bc5719dd7977657ccefff088d418c4e5c SHA512 e290f2045784ba1cf84e87e5bd33129b5452fec1d25da657b084b3561ec76df195a75595248a493dbd85c6a1215ed600332477945922309c021d9e416ebb29ee
+DIST libsass-3.6.4.tar.gz 338519 BLAKE2B 9d312e36e1ac40dcce3aa29728e66643de28da7f2244c8fc987c9a1de7fa0fa72fd5bbd4b5a218c9b53652bd0de469141dbf1b4ddecb7f98405965df946cf333 SHA512 1f79553be31949d45adf440dcbcf4b828a7e4f71c6f63f288f99451fccc490ebf0c68c58d91deabede37962e35a8cf9af8b0d60d89349fd0adea1ac061c8c2c8
diff --git a/dev-libs/libsass/libsass-3.6.4.ebuild b/dev-libs/libsass/libsass-3.6.4.ebuild
new file mode 100644 (file)
index 0000000..70fec39
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} = *9999 ]]; then
+       EGIT_REPO_URI="https://github.com/sass/libsass.git"
+       inherit git-r3
+       KEYWORDS=
+else
+       SRC_URI="https://github.com/sass/libsass/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
+HOMEPAGE="https://github.com/sass/libsass"
+LICENSE="MIT"
+SLOT="0/1" # libsass soname
+IUSE="static-libs"
+
+DOCS=( Readme.md SECURITY.md )
+
+src_prepare() {
+       default
+
+       if [[ ${PV} != *9999 ]]; then
+               [[ -f VERSION ]] || echo "${PV}" > VERSION
+       fi
+       eautoreconf
+
+       # only sane way to deal with various version-related scripts, env variables etc.
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               $(use_enable static-libs static)
+               --enable-shared
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+       find "${D}" -name '*.la' -delete || die
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       dodoc -r "${S}/docs"
+}