net-libs/signond: 8.59 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Oct 2017 19:49:09 +0000 (21:49 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Oct 2017 20:52:42 +0000 (22:52 +0200)
Package-Manager: Portage-2.3.13, Repoman-2.3.4

net-libs/signond/Manifest
net-libs/signond/signond-8.59.ebuild [new file with mode: 0644]

index 6f769c07ba8b41ed9abc428ff14eb603b8c2665b..d3903b334c0770e4945b629c27eaaef3db2aa7a4 100644 (file)
@@ -1 +1,2 @@
 DIST signond-8.58.tar.gz 277287 SHA256 301e2e3b6919585c8ffc56f73ec1f0f9b18a533e1db88461e9fa4e2acf75a34a SHA512 74c9f32ea99c869c0aa72b5816962336869131ea4e8484c53636b35f2ed669a49cbc0ccf10c2c446697892235b94cf2c74f8d5402f430081d7d51421646eec91 WHIRLPOOL 7cff41e9ca37627a6a80a3c23d960958543ee2344ee24771d5e02c6a519d82f68a5003bf9a2bb413c9cbf20f7b450adaf9a82160cd422146431fce237d87d084
+DIST signond-8.59.tar.gz 281298 SHA256 23f6658bf358cc09b858402ee0857db2a2809276625eb01673a0a77969740762 SHA512 b8db03127df7b62dbf046841568c12f29c48c0b3272751600637864caa1c10b05ee9abce20fa41fb8eb7133c6bb20d18ca40803077e9e7808dba5afd108a36bb WHIRLPOOL 67afcc0fcdcc6012f747bab4e2c00e4131ba1e4c92b2742d9772c6b1060d72ceeb711df6785739562f5bf0964bedee69d2ea5f7413eac829131b02fe267d4f19
diff --git a/net-libs/signond/signond-8.59.ebuild b/net-libs/signond/signond-8.59.ebuild
new file mode 100644 (file)
index 0000000..b094d09
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils vcs-snapshot
+
+DESCRIPTION="Signon daemon for libaccounts-glib"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/signond/repository/archive.tar.gz?ref=VERSION_8.59 -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+RESTRICT="test"
+
+COMMON_DEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtsql:5
+       net-libs/libproxy
+"
+DEPEND="${COMMON_DEPEND}
+       doc? ( app-doc/doxygen )
+       test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+       !<net-libs/libproxy-0.4.12[kde]
+"
+# <libproxy-0.4.12[kde] results in segfaults due to symbol collisions with qt4
+
+src_prepare() {
+       default
+
+       # remove unused dependency
+       sed -e "/xml \\\/d" -i src/signond/signond.pro || die
+
+       # ensure qt5 version of binary is used
+       sed -e "s|qdbusxml2cpp|$(qt5_get_bindir)/&|" -i src/signond/signond.pro || die
+
+       # install docs to correct location
+       sed -e "s|share/doc/\$\${PROJECT_NAME}|share/doc/${PF}|" -i doc/doc.pri || die
+
+       # don't install example plugin
+       sed -e "/example/d" -i src/plugins/plugins.pro || die
+
+       # make tests optional
+       use test || sed -i -e '/^SUBDIRS/s/tests//' signon.pro || die "couldn't disable tests"
+
+       # make docs optional
+       use doc || sed -e "/include(\s*doc\/doc.pri\s*)/d" -i \
+               signon.pro -i lib/SignOn/SignOn.pro lib/plugins/plugins.pro || die
+}
+
+src_configure() {
+       eqmake5
+}
+
+src_install() {
+       emake INSTALL_ROOT="${D}" install
+}