dev-python/txaio: Version bump, Adds python 3.7, 3.8
authorBrian Dolbec <dolsen@gentoo.org>
Tue, 28 Apr 2020 01:23:35 +0000 (18:23 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Sat, 9 May 2020 00:50:50 +0000 (17:50 -0700)
metadata.xml: take maintainership

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
dev-python/txaio/Manifest
dev-python/txaio/metadata.xml
dev-python/txaio/txaio-20.4.1.ebuild [new file with mode: 0644]

index def694fd9f6688918d7ff3662601073666291b50..bc247feb76338fe58d05eba4573fb9fda4c119a0 100644 (file)
@@ -1 +1,2 @@
 DIST txaio-2.9.0.tar.gz 44195 BLAKE2B 6c62fc6f17ee860aead90cf5f5d02c7c0d9709adf7bcecbb6a7c1723abf0d8672dbc0b869dfe4683bc26c9608e94c41364add18c22e8e98678de8e10018d991c SHA512 ee07d776fa5894b716fdced36aaa6436336a1f1db97dedb0fd0575d61a7b48b12dfc90ed6078602d7a2c2a00bfa7f815ca76cd75e472a27ff7bfdb56291efa46
+DIST txaio-20.4.1.tar.gz 52580 BLAKE2B 28d745eb9e8a0df1ca8748ce455eb122e240505f31464fcc0e66bafcefa8a01a356e44a46d9a5a1b1c670df46ca0c2ea9e66d29436bf2668e5614c5aa8726cee SHA512 da0269d13d72f4ea14f2e67585cdb74ec5105884c31d81157fb85e92d4eb935b1c13eb1222bd5ecd57a8caa36008cf49de85321e7b67e94159330e1d592d42c4
index e0888e193800192f05a2888f41798c29d6e0303a..e8669e1d3fa05f760e7cfe19a9a54b404df9eca5 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!--maintainer-needed-->
+       <maintainer type="person">
+               <email>dolsen@gentoo.org</email>
+               <name>Brian Dolbec</name>
+       </maintainer>
        <upstream>
                <maintainer>
                        <email>autobahnws@googlegroups.com</email>
diff --git a/dev-python/txaio/txaio-20.4.1.ebuild b/dev-python/txaio/txaio-20.4.1.ebuild
new file mode 100644 (file)
index 0000000..f5c3f1f
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
+               >=dev-python/sphinxcontrib-spelling-2.1.2[${PYTHON_USEDEP}]
+               >=dev-python/sphinx_rtd_theme-0.1.9[${PYTHON_USEDEP}]
+       )
+       test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+       )
+"
+
+src_prepare() {
+       default_src_prepare
+       # Take out failing tests known to pass when run manually
+       # we certainly don't need to test "python setup.py sdist" here
+       rm "${S}/test/test_packaging.py" || die
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       pytest -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}