acct-user/strelaysrv: Add 'strelaysrv' user (UID 496)
authorMarek Szuba <marecki@gentoo.org>
Mon, 1 Jul 2019 10:19:41 +0000 (11:19 +0100)
committerMarek Szuba <marecki@gentoo.org>
Wed, 3 Jul 2019 09:59:25 +0000 (10:59 +0100)
Signed-off-by: Marek Szuba <marecki@gentoo.org>
acct-user/strelaysrv/metadata.xml [new file with mode: 0644]
acct-user/strelaysrv/strelaysrv-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/strelaysrv/metadata.xml b/acct-user/strelaysrv/metadata.xml
new file mode 100644 (file)
index 0000000..3e5026e
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>marecki@gentoo.org</email>
+               <name>Marek Szuba</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/acct-user/strelaysrv/strelaysrv-0.ebuild b/acct-user/strelaysrv/strelaysrv-0.ebuild
new file mode 100644 (file)
index 0000000..4208dc5
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the Syncthing relay server"
+ACCT_USER_ID=496
+ACCT_USER_HOME=/var/lib/strelaysrv
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( strelaysrv )
+
+acct-user_add_deps