net-vpn/protonvpn-cli: new package for protonvpn commandline client
authorILMostro <ilmostro7@gmail.com>
Fri, 21 Feb 2020 04:55:54 +0000 (22:55 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 27 Feb 2020 13:54:42 +0000 (15:54 +0200)
Closes: https://bugs.gentoo.org/710622
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Amel Hodzic <ilmostro7@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14725
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-vpn/protonvpn-cli/Manifest [new file with mode: 0644]
net-vpn/protonvpn-cli/metadata.xml [new file with mode: 0644]
net-vpn/protonvpn-cli/protonvpn-cli-2.2.0.ebuild [new file with mode: 0644]

diff --git a/net-vpn/protonvpn-cli/Manifest b/net-vpn/protonvpn-cli/Manifest
new file mode 100644 (file)
index 0000000..5fe2f60
--- /dev/null
@@ -0,0 +1 @@
+DIST protonvpn-cli-2.2.0.tar.gz 42694 BLAKE2B fb32401580090401cd6c2c3c692313992c62ed24b383c88e006f69f99a6b96e7081d6927778817245c604cb978b2157e88288ab5236211297258b02dc63a197a SHA512 9ff188ddba679187cf69ab2a18023bd030ff8e734cc5f8516cd93490e601cf21482573b2ab0b7586e371c1f83955db1ad66fa98203f3abdf848a0755484c079e
diff --git a/net-vpn/protonvpn-cli/metadata.xml b/net-vpn/protonvpn-cli/metadata.xml
new file mode 100644 (file)
index 0000000..6ad1720
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>ilmostro7@gmail.com</email>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/net-vpn/protonvpn-cli/protonvpn-cli-2.2.0.ebuild b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.0.ebuild
new file mode 100644 (file)
index 0000000..d1f445f
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A VPN command-line tool from protonvpn - python rewrite"
+HOMEPAGE="https://protonvpn.com https://github.com/ProtonVPN/protonvpn-cli-ng"
+SRC_URI="https://github.com/ProtonVPN/${PN}-ng/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/pythondialog:0[${PYTHON_USEDEP}]
+       net-vpn/openvpn"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-ng-${PV}"
+
+DOCS=( CHANGELOG.md README.md USAGE.md )