net-proxy/haproxy: Version bump
authorChristian Ruppert <idl0r@gentoo.org>
Tue, 29 Jan 2019 08:47:15 +0000 (09:47 +0100)
committerChristian Ruppert <idl0r@gentoo.org>
Tue, 29 Jan 2019 08:47:23 +0000 (09:47 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
net-proxy/haproxy/Manifest
net-proxy/haproxy/haproxy-1.9.3.ebuild [new file with mode: 0644]

index 1c0b0271536288a05cd8fc461ece3c473b50310c..9fa05aff503e3be9b451a7a073941e7052d849ad 100644 (file)
@@ -7,3 +7,4 @@ DIST haproxy-1.8.17.tar.gz 2077525 BLAKE2B b4419d541a82399995df448410a8756301ad5
 DIST haproxy-1.8.8.tar.gz 2054534 BLAKE2B 5eabd37dfb79783dc20425cbb16ca1e1afed23861f66c9e8a738dd56d9ca35b3ceb2604c308543ca99222aa867e11ff613fc09012669882a4bdaaff03cb76450 SHA512 8310f84b364348600273c295a3b315a79cba1f782b86b47d8d47b3ffd1e6fb62fd278c4f2dfa185d0a269f73c1067695a763733736877989a941162b625462a1
 DIST haproxy-1.8.9.tar.gz 2057051 BLAKE2B d81d18f68a27ae8a77660c1ecb1dfc28599263ebfd57f25ea574af2b101b35eb7a1a89ba4034b55dfa89673ae6ac4c0dca5428b4b494a02184b1b157850ce96b SHA512 e59c29af3a39d6212f012ae8341b169436e10e42fadaf8f1aa68d2bb7ee181fd1fe3b74640bfcd8c37c17dfc5062b36bd69d90290d7c59cd3e4648ef2ab1c8dd
 DIST haproxy-1.9.2.tar.gz 2350356 BLAKE2B ba147007999d65d214545e5c20567aaa3db67a292eb0df1e1e4aaaeeb7e1c90f593725b112cd222537346cec45b557a2a99e30ef5d4a91bb4b5804212b765121 SHA512 42ad5048c85ac9fdc7ba1b00917508255ffb66f63df1c24382beba6f77765d786b0ab16ddafe5e290f81ea07bd15c63277b5749c4bafab0721e57f837b1bebf8
+DIST haproxy-1.9.3.tar.gz 2353387 BLAKE2B c3b5d7c4dba4a2557dfbee857e8e2a7ab6d142423788c7cabf96c3d0a0dc4a2dde857db47b0036eac7288249d8416eba8252f0c08290739862457214497e3438 SHA512 5ece759d460d6daba8ed82039fb24037c2b8b36f7ce0f9c9a703ca049ac0d03807ba673b61ae2d74a9e7253b6fb1ca82c504734456c7fb0fec322b67e59ba835
diff --git a/net-proxy/haproxy/haproxy-1.9.3.ebuild b/net-proxy/haproxy/haproxy-1.9.3.ebuild
new file mode 100644 (file)
index 0000000..2212a12
--- /dev/null
@@ -0,0 +1,171 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+[[ ${PV} == *9999 ]] && SCM="git-r3"
+inherit user versionator toolchain-funcs flag-o-matic systemd linux-info $SCM
+
+MY_P="${PN}-${PV/_beta/-dev}"
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://www.haproxy.org"
+if [[ ${PV} != *9999 ]]; then
+       SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${MY_P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~ppc ~x86"
+else
+       EGIT_REPO_URI="http://git.haproxy.org/git/haproxy-$(get_version_component_range 1-2).git/"
+       EGIT_BRANCH=master
+fi
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit pcre2 pcre2-jit ssl
+systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
+REQUIRED_USE="pcre-jit? ( pcre )
+       pcre2-jit? ( pcre2 )
+       pcre? ( !pcre2 )
+       device-atlas? ( pcre )
+       ?? ( slz zlib )"
+
+DEPEND="
+       pcre? (
+               dev-libs/libpcre
+               pcre-jit? ( dev-libs/libpcre[jit] )
+       )
+       pcre2? (
+               dev-libs/libpcre
+               pcre2-jit? ( dev-libs/libpcre2[jit] )
+       )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0=[zlib?] )
+               libressl? ( dev-libs/libressl:0= )
+       )
+       slz? ( dev-libs/libslz:= )
+       zlib? ( sys-libs/zlib )
+       lua? ( dev-lang/lua:5.3 )
+       device-atlas? ( dev-libs/device-atlas-api-c )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGELOG CONTRIBUTING MAINTAINERS README )
+CONTRIBS=( halog iprange )
+# ip6range is present in 1.6, but broken.
+version_is_at_least 1.7.0 $PV && CONTRIBS+=( ip6range spoa_example tcploop )
+# TODO: mod_defender - requires apache / APR, modsecurity - the same
+version_is_at_least 1.8.0 $PV && CONTRIBS+=( hpack )
+
+haproxy_use() {
+       (( $# != 2 )) && die "${FUNCNAME} <USE flag> <make option>"
+
+       usex "${1}" "USE_${2}=1" "USE_${2}="
+}
+
+pkg_setup() {
+       enewgroup haproxy
+       enewuser haproxy -1 -1 -1 haproxy
+
+       if use net_ns; then
+               CONFIG_CHECK="~NET_NS"
+               linux-info_pkg_setup
+       fi
+}
+
+src_compile() {
+       local -a args=(
+               V=1
+               TARGET=linux2628
+               USE_GETADDRINFO=1
+               USE_TFO=1
+       )
+
+       # TODO: PCRE2_WIDTH?
+       args+=( $(haproxy_use threads THREAD) )
+       args+=( $(haproxy_use crypt LIBCRYPT) )
+       args+=( $(haproxy_use net_ns NS) )
+       args+=( $(haproxy_use pcre PCRE) )
+       args+=( $(haproxy_use pcre-jit PCRE_JIT) )
+       args+=( $(haproxy_use ssl OPENSSL) )
+       args+=( $(haproxy_use slz SLZ) )
+       args+=( $(haproxy_use zlib ZLIB) )
+       args+=( $(haproxy_use lua LUA) )
+       args+=( $(haproxy_use 51degrees 51DEGREES) )
+       args+=( $(haproxy_use device-atlas DEVICEATLAS) )
+       args+=( $(haproxy_use wurfl WURFL) )
+       args+=( $(haproxy_use systemd SYSTEMD) )
+
+       # For now, until the strict-aliasing breakage will be fixed
+       append-cflags -fno-strict-aliasing
+
+       emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
+       emake -C contrib/systemd SBINDIR=/usr/sbin
+
+       if use tools ; then
+               for contrib in ${CONTRIBS[@]} ; do
+                       # Those two includes are a workaround for hpack Makefile missing those
+                       emake -C contrib/${contrib} \
+                               CFLAGS="${CFLAGS} -I../../include/ -I../../ebtree/" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
+               done
+       fi
+}
+
+src_install() {
+       dosbin haproxy
+       dosym ../sbin/haproxy /usr/bin/haproxy
+
+       newconfd "${FILESDIR}/${PN}.confd" $PN
+       newinitd "${FILESDIR}/${PN}.initd-r6" $PN
+
+       doman doc/haproxy.1
+
+       systemd_dounit contrib/systemd/haproxy.service
+
+       einstalldocs
+
+       # The errorfiles are used by upstream defaults.
+       insinto /etc/haproxy/errors/
+       doins examples/errorfiles/*
+
+       if use doc; then
+               dodoc ROADMAP doc/*.txt
+               #if use lua; then
+               # TODO: doc/lua-api/
+               #fi
+       fi
+
+       if use tools ; then
+               has halog "${CONTRIBS[@]}" && dobin contrib/halog/halog
+               has "iprange" "${CONTRIBS[@]}" && newbin contrib/iprange/iprange haproxy_iprange
+               has "ip6range" "${CONTRIBS[@]}" && newbin contrib/ip6range/ip6range haproxy_ip6range
+               has "spoa_example" "${CONTRIBS[@]}" && newbin contrib/spoa_example/spoa haproxy_spoa_example
+               has "spoa_example" "${CONTRIBS[@]}" && newdoc contrib/spoa_example/README README.spoa_example
+               has "tcploop" "${CONTRIBS[@]}" && newbin contrib/tcploop/tcploop haproxy_tcploop
+               has "hpack" "${CONTRIBS[@]}" && newbin contrib/hpack/gen-rht haproxy_hpack
+       fi
+
+       if use examples ; then
+               docinto examples
+               dodoc examples/*.cfg
+               dodoc examples/seamless_reload.txt
+       fi
+
+       if use vim-syntax ; then
+               insinto /usr/share/vim/vimfiles/syntax
+               doins examples/haproxy.vim
+       fi
+}
+
+pkg_postinst() {
+       if [[ ! -f "${EROOT}/etc/haproxy/haproxy.cfg" ]] ; then
+               ewarn "You need to create /etc/haproxy/haproxy.cfg before you start the haproxy service."
+               ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+               ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+               if [[ -d "${EROOT}/usr/share/doc/${PF}" ]]; then
+                       einfo "Please consult the installed documentation for learning the configuration file's syntax."
+                       einfo "The documentation and sample configuration files are installed here:"
+                       einfo "   ${EROOT}usr/share/doc/${PF}"
+               fi
+       fi
+}