dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild: Add w/v=0.170.880
authorKent Fredric <kentnl@gentoo.org>
Fri, 1 May 2020 02:20:22 +0000 (14:20 +1200)
committerKent Fredric <kentnl@gentoo.org>
Sun, 3 May 2020 14:48:07 +0000 (02:48 +1200)
Required by dev-perl/Dist-Milla, which may be useful for building
dev-perl/App-cpanminus from git sources

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/Dist-Zilla-Plugin-CopyFilesFromBuild-0.170.880.ebuild [new file with mode: 0644]
dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/Manifest [new file with mode: 0644]
dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/metadata.xml [new file with mode: 0644]

diff --git a/dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/Dist-Zilla-Plugin-CopyFilesFromBuild-0.170.880.ebuild b/dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/Dist-Zilla-Plugin-CopyFilesFromBuild-0.170.880.ebuild
new file mode 100644 (file)
index 0000000..2d216cc
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RTHOMPSON
+DIST_VERSION=0.170880
+inherit perl-module
+
+DESCRIPTION="Copy (or move) specific files after building (for SCM inclusion, etc.)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+       dev-perl/Dist-Zilla
+       virtual/perl-IO
+       dev-perl/Moose
+       dev-perl/MooseX-Has-Sugar
+       dev-perl/Path-Tiny
+       >=virtual/perl-Scalar-List-Utils-1.330.0
+       dev-perl/Set-Scalar
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-Carp
+               dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod
+               virtual/perl-File-Spec
+               dev-perl/Test-Exception
+               dev-perl/Test-Most
+               >=virtual/perl-Test-Simple-0.940.0
+               virtual/perl-autodie
+       )
+"
+PERL_RM_FILES=(
+       "t/author-critic.t"
+       "t/author-pod-coverage.t"
+       "t/author-pod-syntax.t"
+       "t/release-has-version.t"
+       "t/release-kwalitee.t"
+       "t/release-portability.t"
+       "t/release-unused-vars.t"
+)
diff --git a/dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/Manifest b/dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/Manifest
new file mode 100644 (file)
index 0000000..1d68661
--- /dev/null
@@ -0,0 +1 @@
+DIST Dist-Zilla-Plugin-CopyFilesFromBuild-0.170880.tar.gz 19810 BLAKE2B cf81e1b3352f2e7c5a7e7da7ebfd1af6cc326b8b97f0b04338db6a26945aa418185016ad1af646cc7adb39a3ce3cf4b72ebe9b9de9e43471fcf28ccf8ddfd96c SHA512 b54b0547ac2955ae9ffdea1c53f77516e487fd7e7f00a22e5a0eb5d16d1f2f540d0036642bf160dbf93d74bacac879d4d9265578053b4244f469f5ace8ca38b3
diff --git a/dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/metadata.xml b/dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild/metadata.xml
new file mode 100644 (file)
index 0000000..5ac9c3f
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>perl@gentoo.org</email>
+    <name>Gentoo Perl Project</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="cpan">Dist-Zilla-Plugin-CopyFilesFromBuild</remote-id>
+    <remote-id type="cpan-module">Dist::Zilla::Plugin::CopyFilesFromBuild</remote-id>
+  </upstream>
+</pkgmetadata>